WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#608 closed defect (duplicate)

Redirect theme and plugin editor function reference to developer.wordpress.org

Reported by: netweb Owned by:
Milestone: Priority: normal
Component: API Keywords:
Cc:

Description

Currently the theme and plugin editor function lookups link to http://phpdoc.wordpress.org/, these should link to the new code reference at https://developer.wordpress.org.

Via http://codex.wordpress.org/WordPress.org_API#Editor

https://api.wordpress.org/core/handbook/1.0/?function={function}&version={wp-version}&redirect=true

e.g. A lookup of register_activation_hook from a plugin is currently redirecting to http://phpdoc.wordpress.org/trunk/WordPress/Plugin/_wp-includes---plugin.php.html#functionregister_activation_hook

This is the same page as http://phpdoc.wordpress.org/ because all other links either no longer exist or are blocked e.g. http://phpdoc.wordpress.org/trunk/ and return 403 Forbidden

Change History (2)

#1 @nacin
3 years ago

There is nothing worth keeping in the code for that handbook endpoint, so it'll need to be new (and open sourced).

Things to keep in mind:

  • Check get_defined_functions() for internal functions and send them off to php.net instead.
  • Redirect them to developer.wordpress.org otherwise.
  • If a function doesn't exist for whatever reason, developer.wordpress.org needs a half-decent 404 page.
  • If $redirect is false, then a simple echo of the target URL occurs.
  • Locale is received but nothing happens with it.
  • Version is received but nothing will happen with it.

#2 @ocean90
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #426.

Note: See TracTickets for help on using tickets.