Making WordPress.org

Opened 2 years ago

Closed 3 months ago

Last modified 2 months ago

#6123 closed defect (bug) (fixed)

Tables in Make handbooks not responsive

Reported by: sumitsingh's profile sumitsingh Owned by:
Milestone: Priority: low
Component: Make (Get Involved) / P2 Keywords: has-screenshots
Cc:

Description

Lots of pages on responsive issue on meta site. Can we fix it. Because most of visitors use mobile device for this platform.
More information see mentioned video.

Attachments (2)

Screenrecorder-2022-02-22-09-35-30-291.mp4 (4.2 MB) - added by sumitsingh 2 years ago.
Scroll past
6123.patch (990 bytes) - added by nidhidhandhukiya 2 years ago.
yiou ahve to add this code in the media query so it can be applied on media only and solved the issue.

Change History (9)

#1 @dd32
2 years ago

  • Component changed from General to Make (Get Involved) / P2
  • Priority changed from normal to low
  • Summary changed from UI issue on Mobile devices. to Tables in Make handbooks not responsive

#2 @sumitsingh
2 years ago

Solution
If we can put font-size 95% for mobile then all pages in tables responsive issue will fixed.

file => https://make.wordpress.org/meta/wp-content/themes/p2-breathe/style.css

html, body, div, span, applet, object, iframe, h1, h2, h3, h4, h5, h6, p, blockquote, pre, a, abbr, acronym, address, big, cite, code, del, dfn, em, font, ins, kbd, q, s, samp, small, strike, strong, sub, sup, tt, var, dl, dt, dd, ol, ul, li, fieldset, form, label, legend, table, caption, tbody, tfoot, thead, tr, th, td {
    border: 0;
    font-family: inherit;
    font-size: 95%;
    font-style: inherit;
    font-weight: inherit;
    margin: 0;
    outline: 0;
    padding: 0;
    vertical-align: baseline;
}

@nidhidhandhukiya
2 years ago

yiou ahve to add this code in the media query so it can be applied on media only and solved the issue.

#3 @dd32
2 years ago

#6136 was marked as a duplicate.

#4 @coffee2code
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed two years ago in [11821] as part of the similar #6139:

Breathe: Make tables horizontally scrollable at smaller viewports.

Does the job, but ideally tables should be truly responsive.

Props multidots1896, hilayt24, coffee2code.
Fixes #6139.

#5 @sumitsingh
2 months ago

Hey @coffee2code , why I haven't received Props in this ticket??

#6 @dd32
2 months ago

@sumitsingh This fix was made two years ago through a different ticket that you didn't participate in, so despite having feedback related to it, you weren't included in that tickets props..

This could've just been marked a duplicate of the closed #6139 instead.

#7 @sumitsingh
2 months ago

But this ticket is old as per existing one. My ticket is 6123 and another one 6139. And I think this ticket should take first and mark another one duplicate. But it's fine 😀

Note: See TracTickets for help on using tickets.