Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6129 closed defect (bug) (fixed)

Multiple Make WordPress Team Selections Not Saved on .org Profile

Reported by: timohaver's profile timohaver Owned by: coffee2code's profile coffee2code
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description

This worked until recently. Perhaps until the addition of the Photos team to the list?

In the WordPress.org profile under the Contributions tab, a user may select multiple Make WordPress teams from a scrollable list, but it appears only one selection is saved. It is always the selection closest to the bottom of the list. For example, if I select Meta and Photos, my profile will only show that I contribute hours to Photos.

I replicated this on the current production of macOS 11.6.2 and 12.2, with the current production version of Safari, Firefox, and Brave.

Attachments (2)

01-wp-profile-contributions-multiple-selections.jpg (21.9 KB) - added by timohaver 2 years ago.
screenshot of multiple selection from the list
02-wp-profile-contribution-text.jpg (11.4 KB) - added by timohaver 2 years ago.
screen shot shows only one o the two selections saved to profile

Download all attachments as: .zip

Change History (7)

@timohaver
2 years ago

screenshot of multiple selection from the list

@timohaver
2 years ago

screen shot shows only one o the two selections saved to profile

#1 @coffee2code
2 years ago

  • Owner set to coffee2code
  • Status changed from new to accepted

#2 @coffee2code
2 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

Thanks for the report!

Fixed in [18490-dotorg]:

Profiles: Ensure multiple Contributor Teams can be selected.

Props timohaver, Otto42, coffee2code.
Fixes #6129.

#3 @dd32
2 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hey @coffee2code This appears to have broken being able to select multiple teams, at least upon edit of ones profile.

Example POST payload as a result of this:

&field_24=Yes
&field_29=38
&field_30[][]=Meta+Team
&profile-group-edit-submit=Save+Changes+
&field_ids=24,29,30
&_wpnonce=12345abcd
&_wp_http_referer=/dd32/profile/edit/group/5/

field_30[][] seems wrong.

This is the cause of the PHP Warnings on WordPress.org:

preg_match() expects parameter 2 to be string, array given

Source: POST https://profiles.wordpress.org/dd32/profile/edit/group/5/
Timestamp: Mon, 21 Mar 2022 03:42:16 +0000 (1647834136)
File: wp-content/plugins/buddypress/bp-xprofile/classes/class-bp-xprofile-field-type.php

#4 follow-up: @coffee2code
2 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

18490-dotorg did "fix" the issue as experienced at the time. It was in largely untouched code so undoubtedly something somewhere else (BP?) had changed its behavior which caused the reported issue. Since then it seems whatever the original issue was has been fixed, so the 18490-dotorg change is no longer needed.

Reverted in [18627-dotorg].

#5 in reply to: ↑ 4 @dd32
2 years ago

Replying to coffee2code:

Thanks! I don't doubt it was originally needed, it looks like the Warnings started March 18th, around the BuddyPress 10.2.0 release, so just for the record, that's where the change probably came from.

Note: See TracTickets for help on using tickets.