Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#6140 closed defect (bug) (fixed)

In support page in responsive width around 800px, there is no left padding.

Reported by: smit08's profile smit08 Owned by: dd32's profile dd32
Milestone: Priority: normal
Component: Support Forums Keywords: has-patch
Cc:

Description

Steps to reproduce:

  1. Open https://wordpress.org/support/ and open in responsive view around 800px or 800px size.
  2. So as you can clearly see there is no padding-left.

I have attached image for better understanding.

Attachments (3)

#6140.patch (552 bytes) - added by kajalgohel 2 years ago.
6140.patch (602 bytes) - added by hilayt24 2 years ago.
The padding is added from 64rem instead of by default. Also, the unit is converted to rem for consistency.
6140.2.patch (582 bytes) - added by nidhidhandhukiya 2 years ago.
If you check other page for example :- https://make.wordpress.org/core/ so they are having 16 px padding in main and the element it self having 20px so total 36 px padding for left and right so for consistency with other pages that will be a better option.

Download all attachments as: .zip

Change History (7)

#1 in reply to: ↑ description @smit08
2 years ago

Replying to smit08:

Steps to reproduce:

  1. Open https://wordpress.org/support/ and open in responsive view around 800px or 800px size.
  2. So as you can clearly see there is no padding-left.

I have attached image for better understanding.

image link: https://prnt.sc/S8CUftidaMGs

@kajalgohel
2 years ago

#2 @kajalgohel
2 years ago

  • Keywords has-patch added; needs-patch removed

#3 @hilayt24
2 years ago

  • Keywords has-testing-info removed

On looking at the issue I found that the issue is coming from 998px, not 800px. Also, we don't need padding by default so instead of that I added the padding from 1024px. Also, the unit should be in rem to maintain consistency in the CSS.

@hilayt24
2 years ago

The padding is added from 64rem instead of by default. Also, the unit is converted to rem for consistency.

@nidhidhandhukiya
2 years ago

If you check other page for example :- https://make.wordpress.org/core/ so they are having 16 px padding in main and the element it self having 20px so total 36 px padding for left and right so for consistency with other pages that will be a better option.

#4 @dd32
2 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 11643:

Support: Add some padding around the homepage content.

Props kajalgohel, hilayt24, nidhidhandhukiya, dd32.
Fixes #6140.

Note: See TracTickets for help on using tickets.