WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#617 closed defect (duplicate)

Inaccessible Profile Icons Have No Text Alternative

Reported by: mrwweb Owned by:
Milestone: Priority: normal
Component: Profiles Keywords:
Cc:

Description

The profile icons (Plugin Developer, Theme Developer, WordPress Speaker, etc.) have no text alternative. They do have a title attribute (is bad), though that's not available to most screen readers by default or touch devices.

At a minimum, the icon markup should include the text from the title attribute hidden but screen reader accessible. Better yet, I think we should strongly consider Nielsen's recommendations about icon usability:

To help overcome the ambiguity that almost all icons face, a text label must be present alongside an icon to clarify its meaning in that particular context...Icon labels should be visible at all times, without any interaction from the user. [original author's emphasis]

I love me some Dashicons, but few of them are anywhere near close to a "universal" icon, and so really would benefit from a universal design approach that displays text labels at all times. But at a minimum, fix the accessibility issue.

Change History (1)

#1 @Otto42
3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #420.

Note: See TracTickets for help on using tickets.