Making WordPress.org

Opened 2 years ago

Closed 17 months ago

#6202 closed defect (bug) (worksforme)

Plugin search ranking

Reported by: gwsharsha's profile gwsharsha Owned by: dd32's profile dd32
Milestone: Priority: normal
Component: Plugin Directory Keywords: close 2nd-opinion
Cc:

Description

https://wordpress.org/plugins/search/ssl/

A plugin like SSL ZEN with lesser reviews, lesser active count and less often updated ranks on very top for the search compared to other plugins with higher reviews, active count. Was there a recent change in search algorithm?, We've noticed the same since months which is not really realistic.

Change History (7)

#1 @dd32
2 years ago

  • Keywords close 2nd-opinion added
  • Priority changed from high to low

There's been no changes to the algorithm that are relevant here, and it looks like it's operating as expected.

There's more fields used other than rating/activecount/description, and it looks like for this query there's a lot of competition as most scores are within a small band.

It's the same reason your plugin is appearing higher than some other plugins that have higher active installs / higher average ratings.

There's a few reasons why the plugins in question are ranking as they are (ie. it's not a single search rule), and while I understand from a business point-of-view that it might seem wrong, from a search perspective it seems ok while balancing the different types of queries it handles.

#2 @dd32
19 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Closing; There wasn't any deliberate change here to cause it, nor was there a deliberate change that has resolved it.

The search results for the provided search are currently:

  • 5m+ Really Simple SSL
  • 50k+ WP Encryption – One Click Free SSL Certificate & SSL / HTTPS Redirect to fix Insecure Content
  • 20k+ SSL Zen – Free SSL Certificate & HTTPS/SSL Redirect for WordPress
  • 10k+ One-Click Free SSL Certificate Plugin for WordPress, HTTPS Redirect – Auto-Install Free SSL

The 5th and 6th results are 100k+ and match closely, so I assume the others listed above have simply used SEO tactics to rank higher.

#3 @gwsharsha
17 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Thank you so much for your honest feedback earlier. Now searching for a keyword like "SSL" brings up caching, maintenance, under construction plugins on very top of search results which is totally inappropriate. Any thoughts on this?

#4 @gwsharsha
17 months ago

  • Priority changed from low to normal

P.S., this changes have been caused by this update - https://wordpress.slack.com/archives/C02QB8GMM/p1672092086124359

#5 @dd32
17 months ago

  • Owner set to dd32
  • Status changed from reopened to accepted

Just noting that my above feedback was prior to the index updates made in the search provider (Elastic search via Jetpack Search).

The current output of the SSL search appears to be reasonable to me, and possibly was something since resolved on their end in response to the feedback in Slack (I'm not sure what the changes were I haven't looked at it, but it was likely a new ES cluster and that requires some changes to the format of the indexes and data documents that ES is ingesting, it can't exactly search through PHP Serialized data).

I'll leave this ticket re-opened until I've reviewed the upstream changes.

Last edited 17 months ago by dd32 (previous) (diff)

#6 @gwsharsha
17 months ago

@dd32 The issue is now resolved as the ES index update was reverted back according to the slack thread. Anyhow there will be an update coming around 2nd week of new year. Feel free to close this ticket for now and I will re-open it if there is any major impact on search results in upcoming update.

#7 @dd32
17 months ago

  • Resolution set to worksforme
  • Status changed from accepted to closed

Thanks @gwsharsha - I'll close this for now as you say, feel free to re-open. Thanks!

Note: See TracTickets for help on using tickets.