Making WordPress.org

Opened 2 years ago

Closed 2 years ago

#6220 closed defect (bug) (fixed)

Trac removing titles shortly after load

Reported by: peterwilsoncc's profile peterwilsoncc Owned by: dd32's profile dd32
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

Identified on core.trac.wordpress.org

Shortly after the page loads, user role badges are removed from each comment (see attached gif).

The cause appears to be the preview AJAX HTTP request happening before any user input is made.

Browser: Firefox 99.0b (Developer Edition)
OS: macOS 11.6

Attachments (1)

6220.gif (122.9 KB) - added by peterwilsoncc 2 years ago.

Download all attachments as: .zip

Change History (3)

@peterwilsoncc
2 years ago

#1 @dd32
2 years ago

This is likely being caused by [11537] (or one of it's followups) calling .change() on the Component input (even if it's not changed) to trigger the notices.

#2 @dd32
2 years ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 11705:

Trac: Change how the "Don't report this here" Trac Redirect works, to avoid triggering a ticket-change, causing the page to reload sans JS enhancements.

Fixes #6220.

Note: See TracTickets for help on using tickets.