Making WordPress.org

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#6376 closed defect (bug) (reported-upstream)

Theme preview is bugged for all themes in the directory

Reported by: superbthemescom's profile superbthemescom Owned by:
Milestone: Priority: high
Component: Theme Directory Keywords:
Cc:

Description

Hi!
The preview is aligned right, and 20% of the content is missing in the view on all themes in the Wp.org directory.

Here's how you reproduce it:

  1. On a website with WordPress installed, go to the themes tab and click "Add new": /wp-admin/theme-install.php?browse=popular
  2. Pick any theme and click "Preview".

This bug doesn't occur on wp.org when clicking the preview button, only on websites with WordPress installed.

Can't figure how to upload images, but the bug is easy to replicate anyways.

The bug is caused by following CSS:

#customize-container iframe, .theme-install-overlay iframe {
    width: 100vw;
}

Changing it to follow, fixes it:

#customize-container iframe, .theme-install-overlay iframe {
    width: 100%;
}

Change History (4)

#1 @joyously
2 years ago

This is actually a problem in core, introduced by changeset [52647](https://core.trac.wordpress.org/changeset/52647) for ticket https://core.trac.wordpress.org/ticket/54764.

This ticket was mentioned in Slack in #meta by joyously. View the logs.


2 years ago

#3 @tellyworth
2 years ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

Closing since this is best handled in the core ticket linked by @joyously.

#4 @SergeyBiryukov
2 years ago

Hi there, welcome to WordPress Meta Trac! Thanks for the ticket.

As the ticket linked above was closed on a completed milestone, I've transferred this report to a new one: #WP56097, let's continue there.

Note: See TracTickets for help on using tickets.