Making WordPress.org

#6392 closed defect (bug) (duplicate)

pre tag broken in theme preview in themes directory - blog themes

Reported by: benimub's profile benimub Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords: theme-preview
Cc:

Description

When you preview blog themes in the theme's repo, the content in pre tag is showing scroll. We can fix it by adding a line of CSS.

If you click on the 'Davis Blocks' theme preview. You can see the scroll bar directly. This is caused by the pre tag.

Broken screenshot: theme-preview-broken.jpg
Fixed screenshot: theme-preview-fixed.jpg
Fixed with code screenshot: theme-preview-fixed-code.jpg

Attachments (3)

theme-preview-broken.jpg (312.9 KB) - added by benimub 15 months ago.
theme-preview-fixed.jpg (300.3 KB) - added by benimub 15 months ago.
theme-preview-fixed-code.jpg (263.7 KB) - added by benimub 15 months ago.

Download all attachments as: .zip

Change History (5)

#1 @benimub
15 months ago

you can add this code in style.css

pre {
    white-space: normal;
}

I have added white-space: normal;

#2 @dd32
15 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6391.

Note: See TracTickets for help on using tickets.