Making WordPress.org

Opened 2 years ago

Closed 19 months ago

#6418 closed enhancement (worksforme)

Append a "Read reply by author" link if there is one on the review overview page

Reported by: renehermi's profile ReneHermi Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch
Cc:

Description

If there are replies (by authors) to reviews, they are not visible at the review overview page that is accessable from the plugin page. E.g Open this review page: https://wordpress.org/plugins/wp-staging/#reviews

The second review with the title "Cool idea, premium is OK but free version is useless" has a reply by the author but it is not visible to an interested user.

Especially if there are reviews that cross the line or contain false claims it would only be fair to give readers the ability to see what a author responded to a particular (bad) review.

If there is an (author) answer, it would be great to have a link to the corresponding answer, like in this screen design:

https://monosnap.com/file/01PKCRUAdSoScr5WaF0wIGeIW1lZt1

This could also reduce author requests for review deletion/edits so it will have a benefit for the review mods as well and not for the plugins devs only.

Slack conversation: https://wordpress.slack.com/archives/C1LBM36LC/p1658314008302899

Change History (11)

#1 @sterndata
2 years ago

Author's replies are already flagged with an orange button. "Read replies by author" is unnecessary.

"Especially if there are reviews that cross the line or contain false claims" False, unfair, etc are in the eyes of the beholder and giving them special treatment is also unnecessary.

"his could also reduce author requests for review deletion/edits " We're cool with the current ways of handling this.

On a page like https://wordpress.org/support/plugin/wp-staging/reviews/, I'm OK with "flagging" an author ID on the right with the same orange button.

#2 @ReneHermi
2 years ago

Hi @sterndata

thanks for your valueable input on this.

Let me explain this more. Maybe I did not explain it good enough what the problem is.

If a user opens the big prominent Review tab on the top of the page https://wordpress.org/plugins/wp-staging/#reviews he will not see that there is a reply to a review. (It does not matter if this reply is by another user or by an author).

It's not intuitive to click on these review title to get more information. Even if a user knows that he can click on a title to get more information he has to click on all titles to eventually see there is a author reply. That's a bad user experience but usually people will only read the full reviews and then will leave that page without any further clicking because its not obvious there is more information hidden behind the titles.

etc are in the eyes of the beholder and giving them special treatment is also unnecessary

I don't think this is giving any special treatment. It's just showing a potential new user of a plugin that there is a reply that could contain interesting extra information about a review.

On a page like https://wordpress.org/support/plugin/wp-staging/reviews/, I'm OK with "flagging" an author ID on the right with the same orange button.

Good catch! That's another spot where a "Read reply" link would be useful or a flag that indicates there is more to read. But not that much as in my first example because the forum list does not show the full reviews instead of only the title. So its much more likey here that a user will click here on that review title to read the rest of the review including potential replies by other users or authors.

Draft:
https://wp-staging.com/ab/images/read-reply.png

Last edited 2 years ago by ReneHermi (previous) (diff)

#3 @sterndata
2 years ago

A "read replies" link when *anyone* has replied is probably unnecessary. I'm not a fan of the page you highlighted; I'd prefer just to go to "all reviews" as the only link for reviews. But, I see your point in the general sense. The problem is that in incetivizes replies and, in general, we don't want reviews to become discussions which turn into gripe sessions or support topics. So, while there is some value to saying "this review has a reply", it does not provide value to the review process, IMHO.

Last edited 2 years ago by sterndata (previous) (diff)

#4 @TimothyBlynJacobs
2 years ago

The problem is that in incetivizes replies and, in general, we don't want reviews to become discussions which turn into gripe sessions or support topics. So, while there is some value to saying "this review has a reply", it does not provide value to the review process, IMHO.

The problem with that, though, is that Plugin authors are told that the best way to handle "unfair" reviews is by leaving a reply.

#5 @sterndata
2 years ago

" Plugin authors are told that the best way to handle "unfair" reviews is by leaving a reply" and that remains true. But we also get folks ("civilians") who want to argue with a review, or add to it, or bring up a support issue, or... Anyhow, not what reviews are about.

#6 @TimothyBlynJacobs
2 years ago

But we also get folks ("civilians") who want to argue with a review, or add to it, or bring up a support issue, or... Anyhow, not what reviews are about.

For sure, but I think noting only when the Plugin Author has left a reply, vs anyone has replied, means adding this information isn't likely to cause negative effects from other users jumping in.

Another potential solution would be to show a snapshot (or full details) of an author's reply on the overview page. Then users wouldn't even get to a comment form.

#7 follow-up: @dd32
2 years ago

Duplicate of / see further discussion in #1805

#8 in reply to: ↑ 7 @ReneHermi
2 years ago

Replying to dd32:

Duplicate of / see further discussion in #1805

Thanks @dd32
That one looks even nicer and more sophisticated.
Is there anything in particular that is preventing the merging?

The problem with that, though, is that Plugin authors are told that the best way to handle "unfair" reviews is by leaving a reply.

+1

#9 @coffee2code
19 months ago

In 12250:

Plugin Directory: Output number of replies (if non-zero) for each review on the reviews tab.

Props hlashbrooke, dufresnesteven, coffee2code.
See #1805, #6418.

#10 @coffee2code
19 months ago

  • Priority changed from high to normal

For future clarification, this ticket differs from #1805 in that this is requesting that the reviews tab indicate if a support representative for the plugin has replied to the review whereas #1805 requested that the replies count (in general) be noted. #1805 has been implemented.

It's a bit more work to determine if a support representative has replied to the review. Even the forum's listing of reviews for a plugin doesn't indicate if that has been the case. It's only known by actually viewing the review thread itself.

Ideally, the support forums would detect (on submission) if it's a support rep reply and set a post meta field value to indicate as much. Then it would be trivial for the Plugin Directory (which is on a different network, though it has direct access to the Support Forum's database) to obtain. The existing reviews and support threads for all plugins and themes would need to be retroactively processed to potentially set the post meta flag.

And, of course, we'll need a mockup to determine, after #1805, how a support rep reply should be denoted.

@ReneHermi: It seems like you may be happy with the solution implemented for #1805. If that's adequate, we can close this ticket. If not, further discussion can be had to decide if it's worth the effort to implement this, which likely won't be soon.

#11 @ReneHermi
19 months ago

  • Resolution set to worksforme
  • Status changed from assigned to closed

@coffee2code Lets close it in favor of already implemented the best possible result with less effort. (#1805)

Note: See TracTickets for help on using tickets.