Making WordPress.org

Opened 2 years ago

Closed 5 weeks ago

#6419 closed defect (bug) (worksforme)

In situ edits of readme does not update properly

Reported by: ipstenu's profile Ipstenu Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description (last modified by Ipstenu)

Edited since this is a little bigger.

Originally:

If a plugin enables release notifications and later makes cosmetic edits to a plugin (such as bumping 'tested up to') _WITHOUT_ making a new version, the change will not be noticed or set live.

This results in developers asking plugins to remove the feature from their plugins.

Recommendation:

If an _active_ tag is changed, allow a release notification

Updated:

Making any edits to the readme without bumping versions results in nothing changing on the front end. This means it's a requirement to release new versions in order to update tested-up-to (for example).

Change History (4)

#1 follow-up: @dd32
2 years ago

If a plugin enables release notifications and later makes cosmetic edits to a plugin (such as bumping 'tested up to') _WITHOUT_ making a new version, the change will not be noticed or set live.

This was kind-of by design. The intention is that the release should not change after approved, even if the tag changes (which realistically, should never happen).

Unfortunately, as we all know though, plugins often need to update tags for readme changes..

I would love if the fix for this wasn't to support tag-updates, but to remove the need to alter the tag.

#2 @Ipstenu
20 months ago

  • Description modified (diff)
  • Summary changed from Plugin Release Notifications Prevent in situ edits of readme to In situ edits of readme does not update properly

#3 @Ipstenu
20 months ago

Updated because this is actually related to the issue where updating a readme won't update the front end of WP or rebuild, so now it's causing people to complain that they updated the readme and it doesn't show any changes.

#4 in reply to: ↑ 1 @dd32
5 weeks ago

  • Resolution set to worksforme
  • Status changed from new to closed

I'm unable to duplicate this now.

There was a change quite some time ago that caused the tagged readme to be imported, which in turn allows the tested up to version to change.

The only case where this is not working AFAIK, is when the release is pending confirmation, the changes won't be reflected on the site until the release is confirmed.

Note: See TracTickets for help on using tickets.