Making WordPress.org

Opened 23 months ago

Closed 7 weeks ago

Last modified 7 weeks ago

#6437 closed feature request (maybelater)

Plugin Directory: an Uninstall Tab is needed on each plugin page

Reported by: ricjcs's profile ricjcs Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Many plugins when deleted leave data in the database. To delete some plugins completely, it is necessary to look in the documentation how to do this, and it is not always easy to find the solution.

The complete uninstallation process is not the same for all plugins, there are different ways for complete removal, such as:

  • turn on some option in plugin settings;
  • add some instruction in functions.php or wp-config.php (e.g. Rank Math SEO and WooCommerce);
  • install another plugin just for the purpose of uninstalling (e.g. Wordfence);
  • manual removal of data in the DB (e.g. Yoast SEO);
  • simply click on the Delete button in the plugins area (usually simple plugins that do not write to the database).

It needs to be indicated in a simple and accessible way, how to uninstall a certain plugin completely, without having to go through Google searches and documentation.

The best way to do this would be on the page for each plugin on wordpress.org, to have an uninstall tab next to the existing installation tab.

Inside this tab would be the information of the data that is created in the database and all the instructions necessary to remove the plugin completely, without leaving any traces in the DB.

Thus, in a simple and fast way users could consult how to remove the plugin correctly.

For small sites, leaving data in the database may not be a big issue, but for large sites that are several years old and have multiple plugins installed over time, removing it completely is essential, so this information should be clearly accessible.

My final suggestion is that the Uninstall Tab should have the following information:

  • How to uninstall the plugin keeping the data in the database
  • How to completely uninstall the plugin, including deleting all data in the database.

Change History (5)

#1 @Ipstenu
23 months ago

Just to clarify, you're saying you want a tab on WordPress.org with UNinstall directions?

Be aware, like most sections, it would be optional.

#2 follow-up: @Otto42
23 months ago

A lot of plugins don't have "pages". The best ones are little standalone that have no uninstall necessary.

But what you're asking for, an "uninstall tab", is just another tab. Doesn't show that people will use it. Doesn't explain why it should be top level. We can invent tabs all day long, but realistically we have only so much space to show them in.

My suggestion would be to standardize the process. We don't need an install tab anymore, because the install is usually just install and activate the plugin. Consider standardizing the uninstall process as well. What would that look like? (Note that this would be a core change, not a meta change.)

#3 in reply to: ↑ 2 @ricjcs
23 months ago

Replying to Ipstenu:

Just to clarify, you're saying you want a tab on WordPress.org with UNinstall directions?

Be aware, like most sections, it would be optional.

For example on the page https://wordpress.org/plugins/jetpack/ there is an installation tab.

My suggestion is that there was the possibility of a tab with instructions for uninstalling in each plugin.

Replying to Otto42:

A lot of plugins don't have "pages". The best ones are little standalone that have no uninstall necessary.

But what you're asking for, an "uninstall tab", is just another tab. Doesn't show that people will use it. Doesn't explain why it should be top level. We can invent tabs all day long, but realistically we have only so much space to show them in.

My suggestion would be to standardize the process. We don't need an install tab anymore, because the install is usually just install and activate the plugin. Consider standardizing the uninstall process as well. What would that look like? (Note that this would be a core change, not a meta change.)

Yes many do not need the uninstall process, but there are many others that do.

An uninstall guide does not guarantee that all users will use it, but it made that information much more visible, and it was no longer necessary to go through Google searches and documentation to know how to completely remove some plugins.

Standardizing the uninstall process would be ideal, but perhaps also the most complicated. While that doesn't happen (and it doesn't seem to be happening in the near future), in my opinion the best thing would be to have an accessible guide.

#4 follow-up: @dd32
7 weeks ago

  • Resolution set to maybelater
  • Status changed from new to closed

Personally; I wish the Install tab would be removed, it provides no benefit.

Plugins can put uninstall instructions in there if they wish though.

Plugins can have uninstall functionality, which cleans up after the plugin. Core supports this.

https://developer.wordpress.org/plugins/plugin-basics/uninstall-methods/

I don't think we need to add an additional tab.

#5 in reply to: ↑ 4 @ricjcs
7 weeks ago

Replying to dd32:

Personally; I wish the Install tab would be removed, it provides no benefit.

Plugins can put uninstall instructions in there if they wish though.

The problem is that a large part of them don't provide instructions.
Whenever I uninstall a plugin I have to check the database to make sure there are no residues left, and very often residues are found, even of simple plugins.

And if we talk about more complex plugins, then the garbage left behind is even greater.

Plugins can have uninstall functionality, which cleans up after the plugin. Core supports this.

supports it, but many plugins don't have this functionality.

If I want to remove a plugin I want my database to be free of plugin junk. The database is the heart of a website, I want my database clean and organized.

For a small site, this garbage may not be a problem, but for large sites that already have many plugins, this garbage makes the database fat. I've seen sites with poor performance and huge databases due to huge amounts of junk plugins that were installed and removed, leaving crap behind.

It doesn't make any sense for me to uninstall a plugin and have to investigate what the plugin left behind in the database, or have to contact support to find out if a certain record actually belongs to a certain plugin and can be safely removed.

There should ALWAYS be the option to remove a plugin completely OR AT THE MINIMUM the developer must indicate which residues are left behind, so that one doesn't have to do a database investigation every time a plugin is removed.

This question becomes even more important since WordPress heavily depends on plugins, as some basic functionalities are still missing.

Currently the process for uninstalling plugins is anarchy.

Note: See TracTickets for help on using tickets.