Making WordPress.org

#6453 closed feature request (duplicate)

Theme directory: Preview style variations

Reported by: poena's profile poena Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

Both Twenty Twenty-Two and Twenty Twenty-Three uses global style variations that can be selected in the Site Editor.
The style variations are additional .json files with global styles settings and styles, placed in the themes styles folder.

When you browse themes, there is no way to preview these style variations.
On the theme information page, the style variations could have a small preview similar to the one in the site editor, where you can see the name of the variation, font choices and colors.
On the demo page, there could be a style variation selector in the sidebar, similar to the one in the site editor.

Attachments (1)

Screen Shot 2022-09-22 at 11.10.04 AM.png (189.0 KB) - added by dufresnesteven 12 months ago.

Download all attachments as: .zip

Change History (5)

#1 @joyously
13 months ago

This is not unique to block themes. Most themes have options that can't be seen in the preview.
The preview site could have a demo Customizer with disabled Publish or just customize_changesets that the theme author supplies for the visitor to see.

#2 @poena
12 months ago

@dufresnesteven I think this ticket should be closed, because I found an older one *laugh*
https://meta.trac.wordpress.org/ticket/6059

#3 @dufresnesteven
12 months ago

Fair enough, I have a big comment I was about to drop :). I'll move it over.

#4 @dufresnesteven
12 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6059.

Note: See TracTickets for help on using tickets.