Making WordPress.org

Opened 18 months ago

Closed 16 months ago

Last modified 16 months ago

#6494 closed defect (bug) (worksforme)

Closed plugins are listed in the search results of the plugin directory

Reported by: zodiac1978's profile zodiac1978 Owned by:
Milestone: Priority: normal
Component: Plugin Directory Keywords: needs-patch 2nd-opinion
Cc:

Description

If you search for plugins on wordpress.org you will get closed plugins in the search results.

Feedback from @dd32 on Slack was:

This shouldn’t have happened. Closed plugins should not show in search results.
This was caused by the metadata for the plugin being out-of-sync with the post status..
It doesn’t look like this is the only case of this.. it appears that the post_status and plugin_status isn’t being sync’d correctly for a bunch of plugins.. I suspect it might be related to self-closures..

just noting that plugin_status not being sync’d is not a problem, it’s unrelated.
I suspect this was actually that the plugin in the search index was outdated, > ElasticSearch thought the plugin was still published, but it wasn’t.. still feels weird it showed up..

Maybe we need to distinguish between permanently closed plugins and pending reviews/temporary closed plugins here too.

Or maybe hiding them is the wrong way here and we should go with the idea from @samuelsidler:

I think it should show in the search results, but 1) at a lower priority / further down the list and 2) should be clear in the search results that the plugin is closed.

Change History (5)

This ticket was mentioned in Slack in #meta by zodiac1978. View the logs.


18 months ago

#2 @dd32
18 months ago

It's worth mentioning, this doesn't affect all closed plugins, only a small number (I can't find a current example).

This occurs when the plugin post_status isn't properly sync'd through to Elastic Search - We use Jetpack Search, so the bug here is likely within the Jetpack syncing process rather than anything we're doing on the Plugin Directory.

#3 @dd32
16 months ago

In 12179:

Plugin Directory: Remove legacy plugin_status meta field.

This field isn't used, and is out-of-sync with the plugin post_status for the vast majority of plugins.

See #6494.

#4 @dd32
16 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

I think I'm going to close this ticket, as there's not much we can really do here.

Closed plugins should NOT show in search results, at least, not intentionally.

The only reason one would, as mentioned in slack, is when the ElasticSearch index is out-of-date with the wp_posts table, which may happen as Jetpack Sync is not always 100% bugfree in my experience. It's usually automatically corrected in the regular data comparison progess though.

While we could add extra filtering on the WordPress.org side, validating that the post id's that Jetpack is saying matches the query actually matches the query, it seems like that's removing most of the point of relying upon it.

#5 @zodiac1978
16 months ago

@dd32 Maybe not for this ticket, but this could be explored further in my opinion:

Maybe we need to distinguish between permanently closed plugins and pending reviews/temporary closed plugins here too.

Permanently closed plugins could be hidden completely, but temporary closed plugins because of ongoing reviews are always creating headaches, because people look for more info and they do not find the plugin at all.

For example: WP Cerber is temporary closed at the moment and not to find in the search:
https://de.wordpress.org/plugins/search/wp+cerber/

In this case, I think the idea from @samuelsidler would be best:

I think it should show in the search results, but 1) at a lower priority / further down the list and 2) should be clear in the search results that the plugin is closed.

Note: See TracTickets for help on using tickets.