Making WordPress.org

#6500 closed defect (bug) (fixed)

"report this topic" text does not show user name if...

Reported by: sterndata's profile sterndata Owned by: dd32's profile dd32
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

If a user has no display/nick name and no name fields, the text for "report this topic" has the reporter's profile link in the markup, but it's invisible because there's no name. See attached images. Example at https://wordpress.org/support/topic/start-here-getting-support-for-thrive-automator/

Attachments (2)

2022-09-22-11-14-48.png (18.3 KB) - added by sterndata 20 months ago.
2022-09-22-11-24-34.png (21.6 KB) - added by sterndata 20 months ago.

Download all attachments as: .zip

Change History (11)

#1 @sterndata
20 months ago

If the user name is blank, just use the userid.

This ticket was mentioned in Slack in #forums by zoonini. View the logs.


20 months ago

#3 @fierevere
20 months ago

There is also same issue with rss feeds, when display name is not set
then creator field is empty.

#4 @dd32
20 months ago

related: #6502 + #4644

This is a known issue.. WordPress doesn't allow for the display_name to be set to nothing, but we have that case on WordPress.org for some reason (bbPress I think is an easy way to trigger it)

Unfortunately WordPress also doesn't have a filter which can be used to handle this properly, which results in the fixes in #4644 not catching everything.

I'm tempted to just say let's close this as a duplicate of #4644, but I'm going to leave this open due to the impact of it.

This ticket was mentioned in Slack in #meta by tellyworth. View the logs.


20 months ago

#7 @fierevere
20 months ago

#6518 was marked as a duplicate.

#8 @SergeyBiryukov
20 months ago

  • Component changed from General to Support Forums

#9 @dd32
20 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 12103:

Support Forums: Ensure that reported topics have a value displayed for who reported a topic.

This fixes get_the_author_meta( 'display_name' ) not returning a value when the WP_User object has an empty display name.

See #4644.
Fixes #6500.

Note: See TracTickets for help on using tickets.