Making WordPress.org

#6513 closed defect (bug) (fixed)

New Core Committers - October 2022

Reported by: desrosj's profile desrosj Owned by:
Milestone: Priority: normal
Component: Version Control Keywords: has-patch
Cc:

Description

Two more contributors been approved for Core SVN commit access:

  • @bernhard-reiter
  • @zieladam

This ticket is to track the tasks needed for onboarding.

Attachments (1)

6513.diff (886 bytes) - added by desrosj 17 months ago.

Download all attachments as: .zip

Change History (5)

@desrosj
17 months ago

#1 @desrosj
17 months ago

I've shared the contributor onboarding documentation in the Core Handbook.

Waiting to receive confirmation that they have completed all steps.

6513.diff adds them to the Trac list for the committer label, but looks like the committer list used in get_committers() was moved to a global variable somewhere else.

Have also added them to:

  • The Core Committers group in Slack
  • WordPress Core Team on GitHub
  • Committer group on Core Trac

#2 @dd32
17 months ago

In 12101:

Trac: Update Contributor labels with new committers.

Props desrosj.
See #6513.

#3 @dd32
17 months ago

Waiting to receive confirmation that they have completed all steps.

Let me know when that's confirmed, and I'll flip the commit switch.

looks like the committer list used in get_committers() was moved to a global variable somewhere else.

Updated!

The centralised list is mentioned at the bottom of https://make.wordpress.org/core/handbook/best-practices/when-you-become-a-committer/ in the steps, making Trac + $committers + SVN Access File the only changes needed from this end.

#4 @desrosj
17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Both contributors have confirmed that they have followed the onboarding checklist. I chatted with @dd32 via Slack DM and commit has now been granted to both!

This should be good to close out.

Note: See TracTickets for help on using tickets.