Making WordPress.org

#6514 closed defect (bug) (reported-upstream)

All search results past page 50 are silently dropped

Reported by: themiked's profile theMikeD Owned by:
Milestone: Priority: normal
Component: WordPress.org Site Keywords:
Cc:

Description

All functions alphabetically after rest_get_authenticated_app_password() are truncated from the list found here https://developer.wordpress.org/reference/functions/page/49/ . Based on discussions in slack (https://wordpress.slack.com/archives/C02QB8GMM/p1664772852191199), this is by design: all results past page 50 are silently dropped, because search engines.

This ticket isn't about the dropping. This ticket is about the list being truncated without any indication that a) there *are* missing results, and b) the missing results can only be seen if the user logs in. The complete lack of feedback for non-logged-in users creates the impression of a broken site.

My suggestion is to implement a message along the lines of, "Please log in to see all results."

Change History (2)

This ticket was mentioned in Slack in #meta by themiked. View the logs.


17 months ago

#2 @tellyworth
13 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

Moving this upstream to the wporg-developer repo: https://github.com/WordPress/wporg-developer/issues/221

This can probably be fixed in the new redesign rollout.

Note: See TracTickets for help on using tickets.