Making WordPress.org

Opened 17 months ago

Closed 17 months ago

Last modified 16 months ago

#6539 closed enhancement (fixed)

Plugin Directory: Support @username format

Reported by: zoonini's profile zoonini Owned by: dd32's profile dd32
Milestone: Priority: normal
Component: Plugin Directory Keywords:
Cc:

Description

Issue

The list of plugins that an author has contributed to in this view:

https://profiles.wordpress.org/username/#content-plugins

...appears to be missing those where the author name in the plugin's readme.txt is set to @username instead of just username.

For example:

https://profiles.wordpress.org/wordpressdotorg/#content-plugins

...is missing this plugin:

https://wordpress.org/plugins/create-block-theme/

From that plugin's readme:

Author: @wordpressdotorg

Potential Solution

Could we consider accommodating the @username format for the plugin's authors / contributors, as it is probably a common oversight to include the @

Compare the previous list with the fuller list here, which does include Create Block Theme:

https://wordpress.org/plugins/author/wordpressdotorg/

Hat tip to @ryelle / ryelle :) for spotting the issue and suggesting a tweak to account for this format.

Change History (8)

#1 @zoonini
17 months ago

Sorry, the subject was meant to be Plugin Directory: Support @username format

#2 @ryelle
17 months ago

  • Summary changed from Plugin Directory: Support to Plugin Directory: Support @username format

#3 @dd32
17 months ago

  • Owner set to dd32
  • Resolution set to fixed
  • Status changed from new to closed

In 12117:

Plugin Directory: Readme parsing: Support those who use the format of @joe-bloggs in the Contributors line.

Fixes #6539.

#4 follow-up: @dd32
17 months ago

[12117] adds support for the @user format, however, doesn't cause this theme to be listed as the Plugin authors have not specified the WordPress.org user as a contributor.

The plugin authors have included an Author: @wordpressdotorg field in the readme, but that's not a valid readme field, so it's ignored. Only Contributors: affects anything.

https://plugins.trac.wordpress.org/browser/create-block-theme/trunk/readme.txt?marks=2-3

#5 in reply to: ↑ 4 ; follow-up: @netweb
17 months ago

Replying to dd32:

The plugin authors have included an Author: @wordpressdotorg field in the readme, but that's not a valid readme field, so it's ignored. Only Contributors: affects anything.

That's interesting, as the wordpressdotorg user was originally displayed!

https://cldup.com/f3A3ZLGggY.png


And the README Validator also throws warnings when @ is included

"One or more contributors listed were ignored. The Contributors field should only contain WordPress.org usernames. Remember that usernames are case-sensitive."

Once you remove the @ symbol from the usernames the validator doesn't display any warnings

p.s The chaosexanima user doesn't exist, so this user needs to be removed from the list to pass validation

https://cldup.com/BVCHiMOofg.png

#6 in reply to: ↑ 5 @dd32
17 months ago

Replying to netweb:

Replying to dd32:

The plugin authors have included an Author: @wordpressdotorg field in the readme, but that's not a valid readme field, so it's ignored. Only Contributors: affects anything.

That's interesting, as the wordpressdotorg user was originally displayed!

When no Contributors can be found, it falls back to the "Owner" of the plugin - and in this case, the plugin post_author is the wordpressdotorg user.

BUT we don't use the post_author anywhere really in the UI, other than on that page as a fallback, everywhere else we only refer to either the Contributor list (including profiles) and we use the Plugins PHP headers for the Authorship line under the header.


And the README Validator also throws warnings when @ is included

"One or more contributors listed were ignored. The Contributors field should only contain WordPress.org usernames. Remember that usernames are case-sensitive."

Yup, Unfortunately it doesn't really get super detailed as to what the issue is, and no-one ever validates their readme's :)

p.s The chaosexanima user doesn't exist, so this user needs to be removed from the list to pass validation

The GitHub user is listed instead, I'm not going to add Github lookups here :) FYI @egregor.

#7 @zoonini
17 months ago

Thanks so much for the quick fix and explanations of the other issues, @dd32 & @netweb !

I put in a GH issue here for Create Block theme to fix all the readme issues. If you see something missing or incorrect, just let me know.

https://github.com/WordPress/create-block-theme/issues/125

#8 @mmaattiiaass
16 months ago

Version 0, edited 16 months ago by mmaattiiaass (next)
Note: See TracTickets for help on using tickets.