WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 10 months ago

#656 closed defect (duplicate)

Dashboard RSS error caused by ASCII control codes.

Reported by: o6asan Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

My site language is Japanese.

Recently, I often have "RSS エラー: This XML document is invalid, likely due to invalid characters. XML error: Invalid character at line xxx, column xx" at rss-widget area on Admin Dashboard.

I found that they came from one of the original topics/replies had a ASCII control code, for example Backspace, Unit Separator and so on.

The reason why it has the ASCII control code might be client application bugs. But I could not find what application had the bug.

If the php scripts for Support Forums get rid of the code by preg_replace or something, it's very convenient. Is it possible?

Thanks in advance.

Change History (2)

#1 @extendwings
3 years ago

  • Cc daisuke@… added

#2 @SergeyBiryukov
10 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Should be fixed with the upgrade to bbPress 2.x in #1544.

Marking as a duplicate of #1320, which has more discussion.

Note: See TracTickets for help on using tickets.