WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 3 years ago

#662 closed defect (fixed)

Component New Ticket link fails on multi-word components

Reported by: kraftbj Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

If the component has multiple words, the link drops after the first space resulting in an invalid component.

Steps to duplicate:

  1. Visit https://core.trac.wordpress.org/component/Bundled+Theme
  2. Click the New Ticket button
  3. Notice the URL is lacking "+Theme" and the Component is set to Administrative (first in list).

Change History (4)

#1 @SergeyBiryukov
5 years ago

Confirmed.

#2 @ocean90
3 years ago

https://core.trac.wordpress.org/component/Bundled+Theme is the same as https://core.trac.wordpress.org/report/31?COMPONENT=Bundled+Theme. The report itself is then using the dynamic variable in

[https://wordpress.org/support/bb-login.php?redirect_to=https://core.trac.wordpress.org/newticket?component=$COMPONENT Create a new ticket]

which outputs "Theme Create a new ticket" because $COMPONENT is not URL encoded.

I've changed the code to

[[https://wordpress.org/support/bb-login.php?redirect_to=https://core.trac.wordpress.org/newticket?component=$COMPONENT|Create a new ticket]]

which outputs

<a class="ext-link" href="https://wordpress.org/support/bb-login.php?redirect_to=https://core.trac.wordpress.org/newticket?component=Bundled Theme"><span class="icon">&#8203;</span>Create a new ticket</a>

But since it's still not URL encoded the space gets lost during the redirect.

#3 @ocean90
3 years ago

#1432 was marked as a duplicate.

#4 @ocean90
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

I've changed the login URL to https://login.wordpress.org/ and fixed the missing spaces in [3146].

Note: See TracTickets for help on using tickets.