Making WordPress.org

#6657 closed defect (bug) (reported-upstream)

Editor crashing while creating a new pattern

Reported by: bhaveshdesai13's profile bhaveshdesai13 Owned by:
Milestone: Priority: normal
Component: WordPress.org Site Keywords: has-screenshots needs-patch
Cc:

Description

The editor for creating new patterns crashes when blocks are removed using the list view.

Steps to recreate the issue:

  1. Go to https://wordpress.org/patterns/new-pattern/
  2. Add any block.
  3. Open the list view.
  4. Remove the block using the block options.

Image: https://share.cleanshot.com/Hpr7VfMLgsXm759wjPhn
Video: https://share.cleanshot.com/CrdPPntNH1Tvb0fgh2F4

TypeError: Cannot read properties of null (reading 'isSynced')
    at e (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/block-editor/index.min.js?ver=036b8eab6943588f121a:90:820)
    at wt (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:47623)
    at vr (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:56438)
    at mr (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:55646)
    at $s (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:124104)
    at wl (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:88644)
    at bl (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:88572)
    at yl (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:88435)
    at fl (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:85592)
    at zn (https://wordpress.org/patterns/wp-content/plugins/gutenberg/build/vendors/react-dom.min.js?ver=18:1:32460)

Attachments (2)

EditorCrashing.jpeg (139.5 KB) - added by bhaveshdesai13 16 months ago.
Bug Image
NewPatternEditorCrashing.mp4 (1.7 MB) - added by bhaveshdesai13 16 months ago.
Bug Video

Download all attachments as: .zip

Change History (4)

@bhaveshdesai13
16 months ago

Bug Image

#1 @dufresnesteven
16 months ago

Hi @bhaveshdesai13, I can reproduce this.

There seems to be a similar issue logged in the theme's repository:

https://github.com/WordPress/pattern-directory/issues/546

Last edited 16 months ago by dufresnesteven (previous) (diff)

#2 @ryelle
16 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

This was reported on GitHub (as mentioned above) and has been fixed there.

Note: See TracTickets for help on using tickets.