Making WordPress.org

Opened 17 months ago

Closed 8 months ago

#6689 closed defect (bug) (fixed)

Right sidebar button text getting cut off on mobile responsive.

Reported by: viralsampat's profile viralsampat Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords: needs-patch dev-feedback reporter-feedback
Cc:

Description

Hello Team,

I have checked the WordPress.org theme section and found that its right sidebar button text getting cut on mobile responsive, especially on screen size between 880px to 960px.

Here, I have attached screenshots.

Please see my attachments.

https://share.cleanshot.com/L1ZnFgpY801tnmMnzpcx

Thanks,

Attachments (2)

6689.diff (436 bytes) - added by viralsampat 17 months ago.
I have checked above mentioned issue and I have resolved it and added patch. Also, I have attached screenshot after resolved this issue.
CleanShot 2023-01-27 at 14.55.03@2x.png (260.3 KB) - added by viralsampat 17 months ago.

Download all attachments as: .zip

Change History (3)

@viralsampat
17 months ago

I have checked above mentioned issue and I have resolved it and added patch. Also, I have attached screenshot after resolved this issue.

#1 @coffee2code
8 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report! I'm not seeing an issue currently in the area being referenced. To be clear, it appears you were specifically pointing out https://make.wordpress.org/themes/.

The text of the second button has changed since this report, which has prevented the root cause of this issue from occurring.

While your solution does prevent the original button text from flowing hidden outside of the boundaries of the button, it is very catered to the specific text there (always forcing a smaller font size via an undesired !important so it just fits) and does not work for even longer text.

Ultimately, sidebar buttons shouldn't have long text and if this issue arises again, that should be the first thing to improve. If this becomes a more pervasive issues, a more robust solution can be pursued.

Note: See TracTickets for help on using tickets.