Making WordPress.org

Opened 18 months ago

Closed 3 months ago

#6703 closed defect (bug) (fixed)

Block editor prevents emojis in reviews

Reported by: clorith's profile Clorith Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

in {11383}, links in reviews were blocked by actively looking for HTTP prefixes (see #5748).

With the introduction of the block-editor for writing reviews, we are now observing that emojis are converted to twemoji img links on the fly, which is causing attempts at writing reviews that include emojis to be blocked by this same link filter.

Change History (3)

#1 @Clorith
18 months ago

Adding additional details here as well for the sake of sharing discoveries, but what has been found has also been shared on the Blocks Everywhere Github repository (issue 135).

The cause appears to be twemoji (this is disabled within the editor screens in wp-admin, not sure what the historical reason for this is).

The twemoji implementation has a global observer, and any time a DOM node is introduced, it looks for any emoji, and converts them to corresponding img tags. When a block goes in/out of edit mode, this introduces a DOM node manipulation, and triggers this observer. This means that reviews (in this example) get an image tag with a link in it added within the editor itself, and also has the unintended effect of causing the block you just wrote to go into recovery mode (as the markup no longer matches what the save function expects).

There is a core ticket that came in recently about the inability to disconnect the observer at this time (#57517), in an ideal scenario we would probably disconnect the observer on DOM ready, so that the initial page load gets the twemoji benefits, but any changes happening after this do not get affected.

#2 @dd32
3 months ago

This should have been resolved via [12341]

#3 @dd32
3 months ago

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.