Making WordPress.org

Opened 18 months ago

Last modified 9 months ago

#6722 reopened enhancement

Support Forums: Timeframe to edit posts or to add further posts should be longer

Reported by: abitofmind's profile abitofmind Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

Timeframe to edit posts

  • Currently limited to 60min.
    • Enough to correct a typo which you spot when looking at your post immediately or soon after publication.
    • Most often not enough to add content corrections which you realize only later.
  • Proposal: Lift that limitation totally (ideal for thread creators, discussion participants, passive readers coming via search engine) or prolong it significantly (acceptable regarding moderation/monitoring effort, min. 7 days)

Pros & Cons

Participants or passive readers

  • Only disadvantages when editing is disallowed too early
  • Must read (lengthy) original and corrected version, inbetween possibly other posts. A lot of scrolling up/down, re-establish context, and putting things together mentally. A lot of redundancy. Unnecessarily hard to digest.

Contributors

  • Many mistakes you only realize later (e.g. after you found out by further research or experimentation, or after a certain mental heureka moment) and as a responsible content creator you want your facts straight, and errors corrected.
  • If you know your audience anyhow will only read it at earliest in X hours (timezone differences, working hours, holidays, etc) you could spare them the whole information genesis and serve them just the evolved result. But you can't.
  • With unlimited editing of the original plus a new post you could provide your forum participants the best of both worlds: Correct in place (and therefore WITH context) plus write a short new post below "I updated the instructions how to do XXX in section YYY in my [original-post](#post-1234)." Your readers get both advantages: A notification + a link to a corrected message WITH context. (No need to put this together mentally yourself).

Forum moderators

  • I don't know your POV, but one rationale I read on #forums on Slack was:
  • Longer timeframe is a longer possibility to edit in new spam links.
  • To me this feels not like a strong argument: Putting spam repeatedly gets you blocked anyhow.
  • The profit of this strategy is very low for spammers: Put a legit post somewhere. Wait until it gets popular in search engines (and receives a high SEO rank). Then somewhen later edit the legit link to a spam link. And then you are caught and blocked. A lot of (almost conspiratory) effort for a one time opportunity (at max 2-3 times) which gets caught sooner/later anyhow. Sounds not like a realistic strategy one needs to fear. But I know little about spam moderation, so correct me if I'm wrong.

Users arriving via search engine or consuming information IN the context of search engine results

  • Significant disadvantages without post-correction:
    • When trusting only the search engine context, they may only get the outdated variant (naive to do that but some certainly do). Search engines are not always that smart, sometimes the outdated info remains stronger in the index than corrected ones. Experienced that far too often on the Internet in general, that I arrive at the irrelevant post, only to learn the corrected solution many posts later.
  • When arriving to the forum, these users have to parse the whole genesis.
  • I see almost no advantages in limiting editing, and hence keep errors frozen as-is.
    • Getting useful information is the prime goal in a tech context.
    • Tracing the genesis of ideas/discourse may be more interesting in political/social discussions.
    • But in a support context, which is sometimes complex and lengthy anyhow, that just feels as a unnecessary burden, which could be avoided simply by being more liberal with the editing timeframe.

Timeframe to add posts to a thread

  • I don't know the limitations.
  • I can just say from observation: In ca 10-20% of my research situations I end up in a forum which is already closed for new entries, which dealt exactly with what I was looking for, but which was left unsolved or with no outcome. And it was maybe only a few months old. Not years. I then sometimes also checked out the plugin or its changelog and it became evident that the situation was still the same. If would have been perfect to just add one more post to already well articulated posts, than to start fresh.
    • Was "gravedigging" a real issue, which could be countered only by the measure of a shorter thread lifecycle?
    • Have you also considered what negative impact this may have? Missed discourse opportunities, higher barrier of entry, etc.

Change History (18)

#1 @abitofmind
18 months ago

One more possible downside of closing a thread too soon:

  • If you discourage searching for existing issues and posting into them (which is considered netiquette)
  • you thereby encourage posting fresh and not care whether that topic is/was already discussed, and hence increase duplicate issues.

#2 @Otto42
18 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

Negative. Having a time frame on the editing of posts is advantageous in that people can't come back later and delete the question.

Look at how useful reddit is a searchable resource (it is not) when people can literally automate it to delete things a few weeks later. There are also cases where people would be deleting their questions because of concerns of "how it would make them look".

As far as thread closure, it's set to a year. Unless it's manually closed earlier than that, a year is plenty of time for discussion to be had.

You can argue that the time frame is too short, but an hour feels like a long time for editing.

#3 @abitofmind
18 months ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

I re-opened this ticket.
The idea is to leave this open and collect pros/cons from multiple perspectives.
Then assess and decide later.

Sorry that I did not express that clearly in the ticket itself.

#4 @abitofmind
18 months ago

  • "Me too" or "+1" comments must also be weighted into the discussion, why a long timeframe may be harmful for forum quality.

#5 @Otto42
18 months ago

Okay.

Cons:

  • Edits allow people to (attempt to) change the past. They get used more for people who wish to abuse the system in some way. People will post a question, get an answer, and then delete the question. Rendering the entire thread pointless in terms of search functionality.
  • @ipstenu: "I will point out that the number one reason I am opposed to allowing edits forever is that people are abusive. I can sing you chapter and verse on the multitudes I’ve had to ban for using the edit to try and hide hateful language. They’ll leave a reply with a terrible message, get it emailed to someone, and then hahhah edit it so mods ‘don’t see.’ Add in the fact that email alerts don’t happen for edits, it strikes me as the wrong direction. If you remember something 7 hours later, leave a reply. It’s okay AND alerts anyone who follows."

The editing window exists for a reason. You can argue that it should be shorter or longer, or whatever, but it didn't have to exist. It originally had to be created for those specific reasons. Those reasons have not changed.

Last edited 18 months ago by Otto42 (previous) (diff)

#6 @abitofmind
18 months ago

Moderators report:

  • Abusive language sometimes is a problem. A short editing window increases the likelihood that this remains visible and the offending actor can not so easily publicly delete evidence thereof and therefore feels more accountable, which increases the chances for a good tone.

(Note by me: Expected this on forums which deal with politics etc. Rather surprised to read that this is an issue on a tech support forum. But yeah, moderators know the dirty reality "behind the curtain")

#7 @Ipstenu
18 months ago

The only real benefit of keeping a post open is that it makes it easier to think of where to reply. But that could be solved by a message and a link "Hey this post is closed, but if you're having the same issue, click here and make your own post!" Give people direction. And bonus you could auto link those back, so the new post links back to the original and gives more context.

Cons of allowing unending edits:

  • No email alerts for edits (only new posts/replies -- can be done, but would have implications on our email service etc, and we already have problems getting blocked for too many emails, like Yahoo...)
  • Not enough existing tracking for what was edited (i.e. we now have to code in more saved revisions and address DB size and how to protray them -- can be done, but hard and messy)
  • Opens us back up to people editing hateful comments to 'hide' them
  • Lost context -- if people change the 'past' then replies don't always make sense (if you've seen those reddit threads "Leave a comment and then edit it to make my reply make me seem evil" that's what we DO NOT want)

Cons of leaving posts open forever:

  • Lack of 'personal' attention. If you reply to MY thread about issue X with a similar one, the people helping now have to context switch between us or, worse, one of us gets ignored.
  • The speed code at which changes means a month old post can be wildly out of date.
  • Longer threads can be hard to narrow down what the problem is, causing poor help
  • If the thread gets massively derailed or problematic, more posts have to be removed, causing context gaps

(Note by me: Expected this on forums which deal with politics etc. Rather surprised to read that this is an issue on a tech support forum. But yeah, moderators know the dirty reality "behind the curtain")

This should surprise no one. Hateful people exist everywhere. Today was someone spouting homophobic and antisemitic content because _Jetpack stops blocking spam when removed._ Seriously. Every community, be it for little kids or adults or seniors, will have this. People are people. If you don't prepare for it, you're going to get burned.

If you're only reactionary (as in you only remove the comments when seen) then you're absolutely missing a TON of things, and you will lose members because they don't want to be around a place that allows that kind of thing (witness the exodus of a certain social media site).

#8 @macmanx
18 months ago

From a moderator standpoint, increasing the edit window will burden the already overspent volunteer moderators.

Many new abuse options have been outlined above; the biggest, in my opinion, would be the ability to initially post with insults/threats (so those are emailed out) and then editing to remove them.

Many issues with leaving threads open forever have been outlined above too, but more open threads = more to moderate.

Unless you can find a way to sustainably double the volunteer team size (as in they stick around after a few weeks), please don’t be surprised if the scale and availability of moderation will be the primary factor here.

Would a larger editing window or leaving threads open forever benefit users? Sure, I can see where that rationale comes from.

Would it be currently impossible to moderate it? Absolutely.

--

From a technical standpoint, several hurdles would need to be crossed before this can happen. It's not just a simple flip of a switch.

As already mentioned, there are no email notifications of edits. The edit window is so small because it's for typos and such. If 2 hours later, you remembered more useful info and you edited the post, there would be no notification of the edit.

So, that would have to be addressed first.

Conversely, you could simply add your 2-hours-later-idea as a reply, and an email notification would be sent.

We have no required way of logging edits. Who changed what, when, and if possible, why? These questions must be answered for edits in any responsible moderated content system.

So, that would also need to be addressed first.

A field explaining the edit will open a spam option, so we'll also need to implement tracking there.

--

In short, it's an interesting idea, and thank you for putting thought into it from a user standpoint.

However, from a moderator and developer standpoint, we are very far from being able to make a change like this today.

More volunteers contributing to the Support Team will be required to help scale us up to handle the added burden: https://make.wordpress.org/support/handbook/

And more volunteers contributing to the Meta Team will be required to help with the additional work that needs to be done to turn this into a feasible option: https://make.wordpress.org/meta/handbook/

#9 @abitofmind
18 months ago

@macmanx I totally agree with you that as you lined out those contributor/reader beneficial changes would needed to be accompanied by other measures, which themselves mean development effort.

  • I can say from self observation that the Gutenberg introduction in the support forums in Late 2022 finally made the Support forums feel like 2022 and not like 2005 (raw HTML entry). This increased my readiness for engagement tremendously.
  • And not being able to edit mistakes (both as a creator and reader) is my second biggest frustration regarding WordPress contribution (support forums, horrible TRAC issue tracker that MANY WordPress projects still use). A real barrier.

@ Automattic executive, who may read this: DevOps / community tools with a contemporary UX (that saves everyone's time & energy) is a true combustion engine for being motivated to contribute. Especially for "occasional" contributors, that low entry barrier is crucial. I believe that money put into this to expedite the improvement process, will show amortization with an increase in voluntary contributions.

#10 @dd32
18 months ago

There's several topics raised in this ticket, and due to it's length, makes it easy to miss them. Ideally, these should have been distinct tickets.

Increase thread edit timeframe

Strong pass from me here, it's not worth the problems it causes. The edit timeframe is for correcting small issues (Typos, formatting, etc) not to reframe the question or correct the initial thoughts. A follow up reply from the thread starter should not be seen as a failure.

Users arriving via search engine or consuming information IN the context of search engine results

Thankfully search engine excerpts are super limited, and you'll almost always have to click through..
Though, this ties into the next point:

Timeframe to add posts to a thread

I've had this same scenario, where I land on a thread that was never replied to or wasn't resolved with the correct information.

I don't necessarily think that adding extra time to add responses is necessarily ideal, but, content discovery could be better - It should be linking similar recent forum posts for a plugin for example, or other resolved topics that are related to the thread.

We don't currently have a way for related-posts style suggestions though, this is likely something that may be viable through a better search engine integration for the Support Forums at some future point in time (It's not a simple task is what I'm saying).

And it was maybe only a few months old. Not years.

I believe it's 6 months from last response, which is a short time, but a looong time for many topics.

This ticket was mentioned in Slack in #forums by abitofmind. View the logs.


18 months ago

#12 @abitofmind
18 months ago

Another use case:

  • Your website could live without a certain plugin/feature for the time being.
  • But e.g. 1 year later you find time for an overhaul/redesign and would like to integrate that feature, you had inquired on a forum support thread back then.
  • Easiest would be a short post like "Any news on this?" possibly with a good reason why the chances may now be better like "Now that obstacle XYZ was fixed in WP x.y.z".
  • But your support thread on that topic is closed for new posts meanwhile.
  • You open a new thread and mention transparently this is a continuation of a meanwhile closed forum thread and link to the old one.

1) Problems now: In at least one instance you moderators applied the policy in a contradicting manner:

2) Another downside of this, negligible, but I want to mention it for completeness:

  • Support forum posts get a permalink https://wordpress.org/support/topic/your-topic-with-max-80-characters
  • You will repost that with a similar title.
  • So you "cludge the namespace". Search engines will have a harder time finding the "definitive article" on the subject in that domain.
  • Only a minimal downside as there are a lot of "-2" and "-3" permalinks in that namespace anyways (especially for short titles)
Last edited 18 months ago by abitofmind (previous) (diff)

#13 @zodiac1978
18 months ago

I would like to add my 2 ct here as I find there are some interesting points made, but burried in all the text.

@Otto42 made a great suggestion in Slack:

If you want an idea to address the problem in your original ticket, how about you can edit until anybody replies? Eliminates the whole problem of people wanting to change the past.

This would help people to optimize their own past if it gets no replies. This would be a great addition IMO.

*

The other point is that auto-closing after 6 months. Coming from the POV of a plugin support rep this can be a problem. Sometimes features are needing more time than 6 months and I couldn't inform user about the new feature. Creating a topic just to ping them seems a bit too much. The same applies for new/better supporters or later found solutions or plugin adoptions/sells and a new team re-checking old threads ...

How about allowing support reps and committers to open threads again or post in them even if they are closed, like mods/admins it can do.

*

And the last point: After creating the topic I have 1 hour to edit it, but what if a mod answers 1 day later and asks for a URL to inspect the page. I cannot edit it and maybe I don't want it to be public.

Allowing "private" (hidden for non-logged in visitors) posts are not available in bbpress, I think, and therefore I can't add my URL to the problematic site without exposing it.

Private posts could fix it or allowing just the edit of the URL (but not sure if both is achievable in bbpress).

*

All those things are valid problems and maybe we can tackle some of them at least for some user groups without opening edits for everyone at any time which would result in big problems (see Twitter not allowing edits).

#14 @abitofmind
18 months ago

"Allowing edits of a post until someone replies" proposal by @Otto42 — Clever balanced proposal! Would improve a significant amount of use cases already. Certainly a candidate for a minimal consensus regarding editing timeframe.

@zodiac1978 thanks for pointing out the perspective of a plugin developer/support-agent or possibly new plugin owner, who should get the opportunity to follow up. And where a different treatment would be technically/administratively easy to implement due to specific user-roles.

Last edited 18 months ago by abitofmind (previous) (diff)

#15 @Ipstenu
18 months ago

Quick hits:

  1. If it's a year later and you need a feature missing in a plugin, the amount of things that will have changed for an in-support/active-maintained plugin are endless. Making a fresh ticket and linking back "Related to X, I have this problem...." is the best way to ensure you get FRESH help and 'today' eyes.
  1. "Please ensure this rule is applied consistently." -- I cannot stress this enough, when you have real humans processing hundreds of things, mistakes will happen. unless you can divine some way to ensure everyone is perfect 100% of the time, you're going to have to live with the reality of imperfect humans, and saying that doesn't actually help.

No two situations are 100% the same, the volunteer moderators are doing their best. Please try to give them the same leniency for a mistake that you'd like for yourself :)

  1. Similar links and -2 and -3 are a fact of life with all forums. It is what it is, and allowing longer edits will never stop 100 people from making posts with the exact same subject "My site broke!"
  1. @zodiac1978 Actually we have a way to make private notes in the forums. That's how the current URL field works. Making a custom URL hidden from view available for all posts in a topic is a nice idea, that would be a good thing to bring up and see if it's feasible. It probably is. Would that be about right?
  1. I'm leery about allowing nod-moderators the ability to reply to long closed posts. Historically speaking, developers are just as likely to flip out and attack users as users are to devs :( I wish that wasn't a thing, but (again) we're all humans and we have feelings that cannot be predicted.

Currently we allow any plugin dev or support rep to mark things as resolved, and that's already been abused by people and kicked off some gnarly fights :(

  1. "Allowing Edits until a Reply" has one flaw - the current system can notify any of a plugin/theme's followers 'So and so made a post!' Allowing infinite edits can turn into a plugin's support rep getting an email about a thing that has little information, and then going and seeing it's totally different so any work you did to solve a problem might be null and void. I don't know if there's a clever way around that, but I don't want to stress out support reps (be they moderators or plugins) more than they are. It's hard work!
  1. "The other point is that auto-closing after 6 months. Coming from the POV of a plugin support rep this can be a problem. Sometimes features are needing more time than 6 months and I couldn't inform user about the new feature."

I mean... not to point a point to it, but if it takes 6 months to make a change, maybe you need a better way to track changes so you could tell people "We've put this on our to do list, but it may be a significant amount of time. Please follow our blog and it'll notify you when we get there."

Otherwise, from a user perspective, y'all ghosted people for 6 months. They probably moved on or gave up.

#16 @zodiac1978
18 months ago

Actually we have a way to make private notes in the forums. That's how the current URL field works.

Yes, but the current URL field is not editable after one hour and after that hour there is no way to add the URL in a non-public way. Correct? Requests for deleting URLs could be solved with making just the URL editable. Although this link could be abused also ...

Making a custom URL hidden from view available for all posts in a topic is a nice idea, that would be a good thing to bring up and see if it's feasible. It probably is. Would that be about right?

Should I open a new ticket for that? Or should we discuss it in a meeting beforehand to refine the idea?

I'm leery about allowing nod-moderators the ability to reply to long closed posts. Historically speaking, developers are just as likely to flip out and attack users as users are to devs :( I wish that wasn't a thing, but (again) we're all humans and we have feelings that cannot be predicted.

I understand you and from my POV as support rep for a plugin this would have been helpful in some threads. But the amount of problems obviously don't outweigh this advantage.

"Allowing Edits until a Reply" has one flaw - the current system can notify any of a plugin/theme's followers 'So and so made a post!' Allowing infinite edits can turn into a plugin's support rep getting an email about a thing that has little information ...

Yes, the 1 hour edit timeframe has the same flaw and I had more than one time the situation of insulting or otherwise bad mail notifications which are changed afterward and not online anymore. Infinite edits until reply would obviously make this problem worse.

*

Although I understand all those issues, I feel a little sad about not optimizing things because there are people out there who want to trick the system and/or harass people. Too bad.

#17 @alh0319
12 months ago

I created a separate ticket (#7161) for not auto-closing threads in case anyone wants to participate in that discussion.

This ticket was mentioned in Slack in #forums by trilos. View the logs.


9 months ago

Note: See TracTickets for help on using tickets.