Making WordPress.org

Opened 17 months ago

Closed 7 months ago

#6736 closed defect (bug) (duplicate)

Navigation menu formatting issue

Reported by: patelhitesh's profile patelhitesh Owned by:
Milestone: Priority: normal
Component: Developer Hub Keywords: needs-patch needs-design-feedback has-screenshots
Cc:

Description

Please check the below URL:
https://developer.wordpress.org/cli/commands/

On the above page, the navigation menus are not looking proper. For more details, please check the attached screenshot:

Attachments (3)

CleanShot 2023-02-07 at 14.19.54@2x.png (84.4 KB) - added by patelhitesh 17 months ago.
Navigation menu formatting issue
CleanShot 2023-02-07 at 17.31.14@2x.png (135.8 KB) - added by kajalgohel 17 months ago.
After adding the padding for nav menu
CleanShot 2023-02-10 at 10.31.54@2x.png (873.7 KB) - added by nidhidhandhukiya 17 months ago.
This is how it looks after adding my given css.

Download all attachments as: .zip

Change History (6)

@patelhitesh
17 months ago

Navigation menu formatting issue

#1 @kajalgohel
17 months ago

Hello @patelhitesh,

Thanks for creating the ticket!

I have checked an issue and am also able to reproduce it.

If it is not intentional then we can add the padding:10px for .menu-container class.

We can add the following CSS for a better view of the nav menu:

@media screen and (min-width: 48em) {
 .menu-container {
    float: right;
    position: relative;
    width: 100%;
    top: auto;
    padding: 10px;
    margin-right: 4px;
 }
}

Thanks.

@kajalgohel
17 months ago

After adding the padding for nav menu

#2 @nidhidhandhukiya
17 months ago

Hello,
I have another solution for it.

@media screen and (min-width: 48em) {
 .menu-container {
    float: right;
    position: relative;
    width: 100%;
    top: -30px;
    padding: 10px;
    margin-right: 4px;
 }
}

@nidhidhandhukiya
17 months ago

This is how it looks after adding my given css.

#3 @coffee2code
7 months ago

  • Component changed from General to Developer Hub
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks to the report and the suggested patches! However, even though this is the earlier ticket, I am closing this as a duplicate of #6981 which was seen and fixed already.

In the future, it's best to try to file tickets into the most appropriate component. That makes it easier for others to see if something was already reported, and it's more likely to be seen and addressed when contributors are reviewing a particular component. While it's fine to use the General component, it's a miscellaneous category that can sometimes delay their handling or have a later duplicate ticket handled first.

Note: See TracTickets for help on using tickets.