Making WordPress.org

Opened 16 months ago

Closed 4 months ago

#6758 closed defect (bug) (fixed)

CORS errors on tracs

Reported by: peterwilsoncc's profile peterwilsoncc Owned by:
Milestone: Priority: normal
Component: Trac Keywords:
Cc:

Description

I've noticed this on meta.trac and core.trac but presume it is happening elsewhere.

There are currently CORS errors thrown on trac due to the use of web fonts. In Firefox 109.0.1/macOS 12.6 I see this error in the browser console when visiting trac.

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://wordpress.org/wp-content/mu-plugins/pub-sync/global-fonts/Inter/Inter-latin.woff2. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing). Status code: 200.

I suspect it's from the global header based on a quick review of the CSS but the content is readable so it's not a serious issue.

Change History (3)

#1 @dd32
16 months ago

I can confirm this is caused by the global header, and lack of CORS headers on the fonts loaded from there.

https://github.com/WordPress/wporg-mu-plugins/pull/173 is the most likely fix for this, serving those static fonts from the CDN instead of from the WordPress.org domains.

#2 @dd32
6 months ago

#7317 was marked as a duplicate.

#3 @dd32
4 months ago

  • Resolution set to fixed
  • Status changed from new to closed

This should be resolved via [13183] (Well, a combination of [13181:13187])

Might take a little longer for some of the Tracs template caches to clear.

Note: See TracTickets for help on using tickets.