Making WordPress.org

Opened 14 months ago

Closed 14 months ago

Last modified 14 months ago

#6761 closed enhancement (invalid)

Enhance UX of navigation in archive pages

Reported by: tresorama's profile tresorama Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

Current State

As a newbie to this community, as I am, I want to read a lot of blog post to understand various part of the community, I want and also to read old posts that instruct me about the history of a WordPress component.

For example, I arrived here for take a look at try to help in "FSE (Full Site Editing)" zone.
To do so, my first idea is :
"Find archive pages, go back in time with pagination, and start to read posts that I think contains Design/Architecture Decision of FSE project, so i can understand how it's evolved over time".

So i found archive pages:

https://make.wordpress.org/test/tag/fse-outreach-program/
https://make.wordpress.org/core/
https://make.wordpress.org/design/

In every of these archive pages, I expect to see a list of post cards with, for every card:

  • post title
  • post date
  • post author
  • tags
  • n of comments(maybe or maybe not)

I don't expect to see, for every card:

  • post content
  • post comments

Instead i found most recent blogpost expanded.
The only want to navigate between posts is to scroll down and go one by one with the "next / prev post" pagination.

What can be improved with this change

What, UX wise, is not possibile at the moment for an user:

  • have an overview of the post and decide which post read
  • know how many post one page has
  • travel in time in the blog post archives

For me this is crucial.

Proposed Solution

  • remove "post content" from post card
  • remove "post comments" from post card
  • add "post tags" to post card
  • add pagination (Prev Page, 1,2,3,4...500, Next Page) to TOP and BOTTOM of the post card's list
  • enojy 😎

Examples for reference:
https://jacopomarrone.netlify.app/blog
https://wordpress.org/news/

Attachments (3)

Change History (7)

#1 @Otto42
14 months ago

  • Priority changed from high to normal
  • Resolution set to invalid
  • Status changed from new to closed

Those are not archive pages. They are the make blogs, and they are where active discussion happens about making the various parts of WordPress.

#2 @tresorama
14 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

With archive i was meaning "directory" not "not relevant anymore".

I used the word "archive" because is how it's named when creating a WordPress Theme, archive of that post type.


To discuss (using comments) you can click on post card and you will be redirected to the "single" post page, where you will active comments at the bottom.
Note that this behavior is already in place right now.


Apart from name, the experience bad anyway IMO.

For example ,
How do you go to a post of 2018?

Version 0, edited 14 months ago by tresorama (next)

#3 @Otto42
14 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Those sites are built on a theme called P2. It is intentionally designed to allow quick posting, commenting on the front page, and other interactions outside of the single page. Additionally, it has a number of features designed to allow cross posting and @ addressing of users, among other things.

In other words, not showing titles is intentional, because posts made with it may not actually have titles. Showing the full content and comments on the front page, as well as on "archive" pages, is intentional as well. P2 is a theme for collaboration and working together on projects, not necessarily for reading as a blog.

In other words, changing the theme to a more traditional blog style theme is not on the table, because it was designed intentionally not to be that.

#4 @tresorama
14 months ago

Those sites are built on a theme called P2. It is intentionally designed to allow quick posting, commenting on the front page, and other interactions outside of the single page. Additionally, it has a number of features designed to allow cross posting and @ addressing of users, among other things.

In other words, not showing titles is intentional, because posts made with it may not actually have titles. Showing the full content and comments on the front page, as well as on "archive" pages, is intentional as well. P2 is a theme for collaboration and working together on projects, not necessarily for reading as a blog.

Slack and Github Issues could be better suited for discussion.
I would use Slack and Github Issues for internal collaboration.
And wordpress.org for publish condensed news, and receive external feedback.

I don't see the point to discuss in two places, it can be source of confusion and require manual sync.
But maybe it's just me and it's not my intention to be rude.

In my opinion a new entry in the community should be able to travel back in time in official press and study the entire system.
It will reduce time to being an active member.


New Proposed Change - Compact View

Let user toggle between compact and an expanded view.
You can see it live right now by using this bookmarklet
Get the Bookmarklet

I did this for myself, and i share here for exploration and posterity.
It's a bookmarklet, that injects a button in the page at the top that toggle "post content" visibility via css.

This could be implemented in the website without a theme redesign.
Maybe under the "Keyboard Shortcut" panel.

For me this is a good compromise, it's not a breaking changes and the consumer can decide if use it or not.

Note: See TracTickets for help on using tickets.