Making WordPress.org

#6764 closed defect (bug) (fixed)

Fix themes XML sitemap

Reported by: jonoaldersonwp's profile jonoaldersonwp Owned by: dd32's profile dd32
Milestone: Priority: high
Component: Theme Directory Keywords: seo
Cc:

Description

The themes XML sitemap seems to be empty.
This should be a sitemap index, referencing a list of XML sitemaps which in turn reference all active themes.

Hopefully this is just a JetPack CMS/config issue, which can be corrected?

Change History (7)

#1 @dd32
15 months ago

  • Owner set to dd32
  • Status changed from new to accepted

Unfortunately this is more than just a Jetpack setting.. I'm looking into it.

#2 @jonoaldersonwp
15 months ago

Damn. Thanks!

#3 @dd32
15 months ago

  • Component changed from General to Theme Directory

Looks like they're back. (And vanished again... and back.. hopefully staying this time?)

The cause seems to be that the database contained 8,400 rows of trashed sitemaps, dating back to 2019.

I'm not sure how or why that would happen, as most other sites I've spot-checked only have them for a week.

I'll have to circle back on this in a few weeks to check that this isn't an ongoing Jetpack bug.

Last edited 15 months ago by dd32 (previous) (diff)

#4 @jonoaldersonwp
15 months ago

Wow! That's fun! :D

#5 @jonoaldersonwp
15 months ago

Oh no, looks like it's empty again!

#6 @dd32
15 months ago

I think I've tracked down what's happening, Just waiting on someone else to get back to me.

#7 @jonoaldersonwp
11 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

This loooooooooks stable now, I think!

Note: See TracTickets for help on using tickets.