Making WordPress.org

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#7017 closed defect (bug) (worksforme)

"Error: Your title is too long." when posting new thread, title in use had 79 characters out of 80 allowed

Reported by: ellmanncreative's profile ellmanncreative Owned by:
Milestone: Priority: lowest
Component: Support Forums Keywords:
Cc:

Description

I tried starting a support forum thread with the topic:

"Alert when someone is locked out" possible to not alert on incorrect username?

-- but on submitting, I received the error message:

Error: Your title is too long.

The field says "Topic Title (Maximum Length: 80):" and it does correctly limit to the 80 characters.

Change History (2)

#1 follow-up: @Clorith
9 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Hi there, and welcome to the meta trac!

What has likely happened here is that your quotation symbols have not been "plain" quotes, but rather texturized ones (these are slightly more stylized, and count as 2 characters due to their encoding), the difference is very subtle between the two (texturized) vs " (plain).

This is part of how bbPress handles the check for topic length (they have their own trac for bugs with bbPress), which is where any issues with this matching should happen.

I'm not sure the WordPress.org forums should force regular strings (because the use of texturized symbols may be intentional), or filter how bbPress looks up the length, since this may be tied into other areas of the software as well, so they would be the best suited to make a call on if their checks are no longer as relevant :)

Since this is within the base bbPress code, and technically works as intended, I'm going to close the ticket as worksforme, but knowing the bbPress devs, they would certainly welcome any discussion on potential better approaches, so I encourage you to pick this up over there!

#2 in reply to: ↑ 1 @ellmanncreative
9 months ago

Replying to Clorith:

What has likely happened here is that your quotation symbols have not been "plain" quotes, but rather texturized ones (these are slightly more stylized, and count as 2 characters due to their encoding)

Possible. As I now look at the thread I started, it does have these "pretty" marks instead of the regular ones.

I entered them with my keyboard, but it's possible I copied the Title back out for some reason.

Does the Forum script "prettify" these? Because I otherwise have to go out of my way to enter these prettier versions, and I don't remember doing that.

Note: See TracTickets for help on using tickets.