Making WordPress.org

Opened 12 months ago

Closed 12 months ago

Last modified 12 months ago

#7076 closed defect (bug) (fixed)

Theme Directory Search Functionality Issue

Reported by: athemeart's profile athemeart Owned by: dufresnesteven's profile dufresnesteven
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

Hello,

I recently discovered a bug on the WordPress.org theme directory. The issue revolves around the search bar, which is not functioning correctly. To provide a clearer understanding of the problem, I have attached a video demonstration at this link: https://streamable.com/1i4u71

Please take a look at the video to see the bug in action.

Thank you

Attachments (1)

WordPress Themes _ WordPress.org.mp4 (1.7 MB) - added by athemeart 12 months ago.

Download all attachments as: .zip

Change History (7)

#1 @dufresnesteven
12 months ago

Thanks for the report! Can you provide the steps to reproduce?

While sharing a video can be helpful it shouldn't be considered as the main source to report an issue because it isn't accessible to everyone.

Thanks.

#2 @kafleg
12 months ago

Hello @dufresnesteven

The search bar works fine in the /themes page but it is not working on the single theme page.

If you visit the page https://wordpress.org/themes/twentytwentythree/ and try to search the theme, the ajax search won't work and we need to hit enter to search the theme. We get the result but the search is not smooth.

#3 @athemeart
12 months ago

Hello,

When I enter a keyword without a space after it, the resulting URLs redirect to variations that only include one or two words of each keyword.

For example, if I type "fashion" into the search bar and hit the enter key, the expected URL should be "https://wordpress.org/themes/search/fashion/". However, the actual redirected URLs appear as follows:

https://wordpress.org/themes/search/h/?
https://wordpress.org/themes/search/f/?
https://wordpress.org/themes/search/fa/?

After the redirect on the search page, the input box does not retain the previously entered keyword for preview or editing.

I hope this information helps you in identifying and resolving the issue. If you require any further assistance or clarification, please let me know.

Thank you for your attention to this matter.

Best regards,

#4 @dufresnesteven
12 months ago

  • Owner set to dufresnesteven
  • Resolution set to fixed
  • Status changed from assigned to closed

In 12666:

Themes: Fix single page search.

Fixes: #7076
Props: athemeart, kafleg

#5 @dufresnesteven
12 months ago

I think I have it fixed in the previous commit.

Please confirm and reopen if there are any related issues.

I do see there is an inconvenient reload of the content. I don't think it's related but I may take some time to figure out what is causing that.

Thanks again!

#6 @athemeart
12 months ago

Hi @dufresnesteven

Yes it's working better now !

Thanks

Note: See TracTickets for help on using tickets.