Making WordPress.org

Change History (7)

#1 follow-up: @dd32
11 months ago

  • Priority changed from highest omg bbq to normal
  • Resolution set to fixed
  • Status changed from new to closed

These are human written pages, this isn't a case of 'forgery' rather human error.

https://wordpress.org/documentation/wordpress-version/version-6-1/

Page created on 17th April 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

https://wordpress.org/documentation/wordpress-version/version-6-1-1/

Page created on 17th May 2023 with the incorrect date.

https://wordpress.org/documentation/wordpress-version/version-6-1-2/

Page created on 16th May 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

I've updated all with the correct 2022 date.

It looks like these pages were created late, so didn't exist at release time.

It appears that the cause was that a bunch of older point releases were created, such as 5.3.15 https://wordpress.org/documentation/wordpress-version/version-5-3-15/ with 2022 as the year, where it should've been 2023. While updating those to the correct 2023 release date the 6.x.x pages were incorrectly included in the set of posts that were updated.

#2 in reply to: ↑ 1 ; follow-up: @anrghg
11 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Summary changed from Forged release dates to be reverted to initial to Mistaken release dates to be reverted to initial

Replying to dd32:

Thanks for correcting.

This kind of errors is typically due to nootropics caffeine, theobromine and theophylline.

https://wordpress.org/documentation/wordpress-version/version-6-1/

Page created on 17th April 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

First published November 2, 2022”

https://wordpress.org/documentation/wordpress-version/version-6-1-1/

Page created on 17th May 2023 with the incorrect date.

First published November 14, 2022”

https://wordpress.org/documentation/wordpress-version/version-6-1-2/

Page created on 16th May 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

I've updated all with the correct 2022 date.

My bad. I cited the 6.1.2 page for reference only, not for correction. But now it reads:

On May 16, 2022, WordPress 6.1.2 was released to the public.

(Bold added.)

It appears that the cause was that a bunch of older point releases were created, such as 5.3.15 https://wordpress.org/documentation/wordpress-version/version-5-3-15/ with 2022 as the year, where it should've been 2023. While updating those to the correct 2023 release date the 6.x.x pages were incorrectly included in the set of posts that were updated.

That makes sense to me. And now that sort of mess has unfolded the other way around.

#3 in reply to: ↑ 2 ; follow-up: @dd32
11 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to anrghg:

https://wordpress.org/documentation/wordpress-version/version-6-1/

Page created on 17th April 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

First published November 2, 2022”

For whatever reason, those First Published dates don't match the page edit history. The publish can be set manually, so it's likely been back-dated OR the revision history has been broken for some reason (which is a high possibility). The docs team would have to weigh in.

https://wordpress.org/documentation/wordpress-version/version-6-1-2/

Page created on 16th May 2023 with the correct date, Mistakenly updated to 2023 on 17th May.

I've updated all with the correct 2022 date.

My bad. I cited the 6.1.2 page for reference only, not for correction. But now it reads:

On May 16, 2022, WordPress 6.1.2 was released to the public.

(Bold added.)

Gah. I was even cross-referencing those with the release lists, and even I mistook the 6.1.x dates :)
Reverted my change. It reads 2023 again.

This ticket was mentioned in Slack in #docs by dd32. View the logs.


11 months ago

#5 in reply to: ↑ 3 @anrghg
11 months ago

Replying to dd32:

No problem.

#6 @estelaris
11 months ago

There is an issue opened in the GitHub docs issue tracker https://github.com/WordPress/Documentation-Issue-Tracker/issues/880 about this. My last comment has the full list. The errors are only on versions 6.1.2 and 6.1.3. The issue will be tracked in GitHub

#7 @dd32
11 months ago

  • Resolution changed from fixed to reported-upstream
Note: See TracTickets for help on using tickets.