Making WordPress.org

Opened 11 months ago

Closed 5 months ago

#7138 closed defect (bug) (fixed)

Dropdown should have some effect like cusror pointer or hover effect

Reported by: pitamdey's profile pitamdey Owned by:
Milestone: Priority: lowest
Component: HelpHub (wordpress.org/documentation) Keywords: has-screenshots has-patch
Cc:

Description

URL: https://wordpress.org/documentation/article/blocks-list/#wp--skip-link--target
The dropdown should have some hover effect or there should be at least cursor pointer to make the design proper

Attachments (3)

Screenshot 2023-07-13 at 8.09.01 PM.png (373.2 KB) - added by pitamdey 11 months ago.
screenshot for better understanding
7138.patch (17.8 KB) - added by pitamdey 11 months ago.
after applying this solution the issue is resolved
7138.diff (527 bytes) - added by shailu25 10 months ago.
Patch Added

Download all attachments as: .zip

Change History (8)

@pitamdey
11 months ago

screenshot for better understanding

@pitamdey
11 months ago

after applying this solution the issue is resolved

#1 @pitamdey
11 months ago

we can add cursor pointer to the .wporg-table-of-contentsheader button
i.e. .wporg-table-of-contents
header button{cursor: pointer}
we can also add hover effect on this class

#3 @pitamdey
11 months ago

Thanks @dufresnesteven
yes we can add the CSS in following class

.wporg-table-of-contents__header {

	& button {
		cursor:pointer
	}
}

@shailu25
10 months ago

Patch Added

#4 @shailu25
10 months ago

  • Keywords has-patch added

#5 @coffee2code
5 months ago

  • Component changed from Make (Get Involved) / P2 to HelpHub (wordpress.org/documentation)
  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the report and the patches! The theme for the Documentation site was completely changed recently and the new theme does not exhibit the issue reported here. The "In this article" sidebar widget no longer functions as something that can be collapsed.

Note: See TracTickets for help on using tickets.