Making WordPress.org

Opened 11 months ago

Closed 4 months ago

#7140 closed enhancement (wontfix)

Slackbot to generate a ping when Plugin Review team sends initial review email

Reported by: zoonini's profile zoonini Owned by:
Milestone: Priority: low
Component: Plugin Directory Keywords:
Cc:

Description

Members of the Plugin Review team have noticed that when they email a user who's submitted a plugin with the initial review, about 80% of people never reply. This stops the review from progressing and prevents the plugin from ever getting into the repo.

It also accounts for a lot of review time that's potentially wasted.

In case emails from plugins@… are being missed by the submitter – perhaps caught in a spam filter or otherwise not being seen – let's create a Slackbot to ping the user in Slack, in addition to the email.

The message could say something like:

"Heads-up: your plugin has been reviewed. Please check your email, including any spam folders, for a message from plugins@…. If you can, please also whitelist this address to ensure deliverability of future correspondence from the Plugin Review team.

This important message contains the details of your initial review, with a list of items to be addressed to move on to the next step.

If you have not received the email, please ping in #pluginreview with the name of your plugin, so we can investigate."

Change History (11)

#1 @davidperez
11 months ago

I think is very convenient to ping the user if they've missed the email.

Totally agree.

#2 @Ipstenu
11 months ago

If you have not received the email, please ping in #pluginreview with the name of your plugin, so we can investigate."

You may want to tweak ... "with the name of your plugin and the username of the submitter (if it isn't your ID)"

A lot of people submit via one account and use slack with another, and it's a BEAR to figure out who was supposed to get the notice.

#3 @zoonini
11 months ago

@Ipstenu Excellent tweak, thank you!

#4 @martatorre
11 months ago

I think it's a good idea, but I wonder if all plugin developers have a slack account or with another WordPress user account??

#5 follow-up: @zoonini
11 months ago

@martatorre Yes, good point indeed, we would potentially miss people like:

  • plugin devs without a Slack account
  • plugin devs who submitted a plugin under one user account, but use a different account in Slack

Still, if the Slackbot could reach some of the users who currently aren't responding to the emails, it would be better than nothing!

#6 in reply to: ↑ 5 @martatorre
11 months ago

@zoonini Yes, I think it is better to reach a few than none. For my part, I think it is a good idea.

#7 follow-up: @dd32
11 months ago

  • Component changed from Slack & IRC to Plugin Directory
  • Priority changed from normal to low

First issue that comes to mind is that we don't currently really know that an email has been sent to the dev when the plugin was moved to pending.

I'm assuming that most reviewers set it to pending before the email is sent.

Looking at the current queue tells me this is not worth the effort though:

Total authors in Pending + New 1,354
Authors with a Slack account 144
Requested a Slack invite,
and not signed in
10

Realistically, the issue is that most plugins get submitted from brand-new accounts these days, even if the author has a long-term account, they tend to create a dedicated plugin account (Whether this is to work around the one-plugin-in-review-per-account, trademark/ownership rules, or just basic ownership issues, idk).

Moving this to low due to the low level of impact this seems like it'll have, Plugin Directory since this primarily concerns the plugin directory.

#8 in reply to: ↑ 7 @dd32
11 months ago

Replying to dd32:

Realistically, the issue is that most plugins get submitted from brand-new accounts these days, even if the author has a long-term account

The second part of this thought was.. Perhaps we should be asking for the committers account(s) or best contact email address during the submission process

#9 follow-up: @chriscct7
11 months ago

Perhaps we should be asking for the committers account(s) or best contact email address during the submission process

My concern with this approach is that users might expect this to be the email we contact them moving forward with for Plugin Security or Guideline violations or for the WordPress Core upcoming release emails, because those emails go out on the User's WordPress.org profile. I think if we did this we would need to accompany it with some sort of like bolded notice that this is a one time contact and they need to go fix their user account email address so that they are receiving emails from WordPress.org or something, or otherwise we might be just delaying the contact problem from the initial submission to whenever the next major release all plugin author email goes out.

#10 in reply to: ↑ 9 @dd32
11 months ago

Replying to chriscct7:

Perhaps we should be asking for the committers account(s) or best contact email address during the submission process

My concern with this approach

True.. If we were to ask for the committers, it could be a list of WordPress.org users (ie. not an email address), and auto-added as committers upon approval..

But, I don't think the benefit is here, if the email address of the account that submits it isn't a good contact, we probably want them to fix THAT rather than work around it.

#11 @dd32
4 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

I'm going to close this as wontfix due to the low number of plugin authors with a Slack account, and the difficulty in detecting that an email was actually sent regarding a plugin.

I also question if those who do have a Slack account, sign into it regularly, given that any notifications sent to that Slack would ultimately also be sent to their email address on record for the account.

We can reconsider this later if needed, but for now I'm going to close this as something we're not going to put development time into.

Note: See TracTickets for help on using tickets.