Making WordPress.org

Opened 7 months ago

Closed 7 months ago

#7204 closed defect (bug) (fixed)

Capital B in Blocks for the new URL breaks theme output

Reported by: ipstenu's profile Ipstenu Owned by: otto42's profile Otto42
Milestone: Priority: normal
Component: WordPress.org Site Keywords:
Cc:

Description

From @courtneyRobertson

Buttons aren't looking quite right https://github.com/WordPress/wporg-main-2022/issues/245#issuecomment-1675247771. Pinging only as that Meta post is out and drawing attention to this.

Per ryelle:

The issue is the capital in the url that's causing the wrong theme to load

Attachments (1)

redirect.diff (601 bytes) - added by Ipstenu 7 months ago.
Hotfix

Download all attachments as: .zip

Change History (6)

@Ipstenu
7 months ago

Hotfix

#1 @alexstine
7 months ago

Patch looks good.

#2 @Ipstenu
7 months ago

  • Resolution set to fixed
  • Status changed from new to closed

#3 @ndiego
7 months ago

The patch works great on desktop, but I am still seeing the old site on mobile. Weird.

#4 @Otto42
7 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

As far as I can tell, this code doesn't work at all. That entire function only runs for a 404 case.

https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/mu-plugins/pub/wporg-redirects.php?rev=12836#L118

#5 @Otto42
7 months ago

  • Owner set to Otto42
  • Resolution set to fixed
  • Status changed from reopened to closed

In 12837:

Temp fix for blocks, rm as soon as possible. Fixes #7204

Note: See TracTickets for help on using tickets.