Making WordPress.org

Opened 9 months ago

Closed 6 months ago

Last modified 6 months ago

#7218 closed defect (bug) (fixed)

Data Request screen not fully responsive

Reported by: akureshi's profile akureshi Owned by: coffee2code's profile coffee2code
Milestone: Priority: lowest
Component: WordPress.org Site Keywords: changes-requested
Cc:

Description

in mobile view page overflow horizontal for button text is very long as screen width.

Attachments (1)

Data Erasure Request _ WordPress.org.mp4 (6.2 MB) - added by akureshi 9 months ago.
Design Break in Mobile Responsive

Change History (6)

@akureshi
9 months ago

Design Break in Mobile Responsive

#1 @dd32
9 months ago

  • Keywords needs-design needs-design-feedback removed
  • Priority changed from normal to lowest
  • Summary changed from Design Break in Mobile Responsive to Data Request screen not fully responsive

Hello,

Please always include a link to the page in question.

https://wordpress.org/about/privacy/data-erasure-request/

The specific issue is that the input[type="submit"] does not wrap, and the label is too wide for the screen width chosen in the video.

I believe this is a duplicate of another issue, but I'm not going to search for it right now.

This probably won't be fixed directly, as this page is one of the few remaining pages to be migrated to a new theme: https://github.com/WordPress/wporg-main-2022

#2 @ruchirj
9 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

Changes white-space: nowrap; to white-space: normal; below this code work fine.

.button, .button-primary, .button-secondary, .plugin-upload-form .button-primary, input[type=submit]{

white-space: normal;

}

#3 @ruchirj
9 months ago

  • Keywords changes-requested added
  • Resolution reported-upstream deleted
  • Status changed from closed to reopened

Changes white-space: nowrap; to white-space: normal; below this code work fine.

.button, .button-primary, .button-secondary, .plugin-upload-form .button-primary, input[type=submit]{

white-space: normal;

}

#4 @coffee2code
6 months ago

  • Owner set to coffee2code
  • Resolution set to fixed
  • Status changed from reopened to closed

In 13005:

Main, Data Erasure Request: Prevent permanent account deletion button from flowing beyond the viewport width.

Props ruchirj, akureshi.
Fixes #7218.

This ticket was mentioned in Slack in #meta by courtneyengle. View the logs.


6 months ago

Note: See TracTickets for help on using tickets.