WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#729 closed defect (fixed)

RTL for wp.org local sites (rosetta)

Reported by: ramiy Owned by: ocean90
Milestone: Priority: normal
Component: International Sites (Rosetta) Keywords:
Cc:

Description

Hi guys,
it's Rami from he.wordpress.org.

Seems like the RTL version of rosetta is broken. Or, the theme was changed but the he_IL.css file was not updated accordingly.

You need to delete:

.wrapper { width: 858px; }

Attachments (1)

729.patch (2.0 KB) - added by ocean90 5 years ago.

Download all attachments as: .zip

Change History (16)

#1 @SergeyBiryukov
5 years ago

Confirmed. he_IL.css was removed in i18n:22662 (apparently it was no longer needed after [WP26783] and [WP26816]), but it still exists on global.wordpress.org.

#2 @ramiy
5 years ago

I confirm your confirmation, removing he_IL.css fixes all UI issues in http://he.wordpress.org/.

#3 @ramiy
5 years ago

Now i see that the site and the dashboard are both ltr.

#4 @ramiy
5 years ago

You need to set it as rtl to load the missing rtl.css file.

#5 @samuelsidler
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Nacin fixed this up earlier today.

#6 @SergeyBiryukov
5 years ago

I still see he_IL.css loaded on the page with .wrapper { width: 858px; } in it. Is it supposed to be there? [987] didn't cover that.

#7 @ocean90
5 years ago

he_IL.css was re-added. I removed it from l18n repo and deleted it again. Seems like we also need a version bump for [987].

#8 follow-up: @ocean90
5 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Okay, we're talking about two different he_IL.css files. One which had existed in /wp-content and one in /rosetta. The one which is removed now is /rosetta. But that will break the site layout because not all styles are in wp4-rtl.css yet. I will try to migrate all the neccessay changes from he_IL.css to wp4-rtl.css now.

@ocean90
5 years ago

#9 @ocean90
5 years ago

After some coffee I noticed that we have rtl.css for Rosetta which I had deleted locally and therefore comment:8.

So the only thing we have do is to reset the font, see 729.patch. (Includes some clean up.)

#10 in reply to: ↑ 8 ; follow-up: @SergeyBiryukov
5 years ago

Replying to ocean90:

Okay, we're talking about two different he_IL.css files. One which had existed in /wp-content and one in /rosetta. The one which is removed now is /rosetta.

FWIW, I still see the one from /wp-content in the page source:
http://global.wordpress.org/wp-content/languages/css/he_IL.css?1416136182&ver=1

#11 in reply to: ↑ 10 @ocean90
5 years ago

Replying to SergeyBiryukov:

FWIW, I still see the one from /wp-content in the page source:

It's not deployed yet.

#12 @samuelsidler
5 years ago

In 992:

Rosetta theme: Fix some RTL issues. see #729. props ocean90

#13 @samuelsidler
5 years ago

We still need the wp4-rtl.css changes in the patch.

#14 @ramiy
5 years ago

Greate work guys, thanks!

#15 @ocean90
5 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from reopened to closed

In 1066:

Further clean-up of global RTL styles.

fixes #729.

Note: See TracTickets for help on using tickets.