Making WordPress.org

Opened 8 months ago

Closed 8 months ago

Last modified 7 months ago

#7295 closed defect (bug) (fixed)

Broken footer on https://core.trac.wordpress.org/ and https://meta.trac.wordpress.org/

Reported by: sumitsingh's profile sumitsingh Owned by: ryelle's profile ryelle
Milestone: Q1 Priority: normal
Component: WordPress.org Site Keywords: has-screenshots
Cc:

Description

Hey,

Can you check why the footer looks broken right now here https://core.trac.wordpress.org/ and https://meta.trac.wordpress.org/?

I am sharing the screenshot.

Attachments (2)

Ticket-7295-–-Attachment-–-Making-WordPress-org.png (76.7 KB) - added by sumitsingh 8 months ago.
Broken footer screenhsot
Screenshot-from-2023-10-03-16-57-34.png (299.8 KB) - added by sumitsingh 8 months ago.
Should be look like this footer

Download all attachments as: .zip

Change History (11)

@sumitsingh
8 months ago

Should be look like this footer

This ticket was mentioned in Slack in #community-team by sumitsingh. View the logs.


8 months ago

#2 @sumitsingh
8 months ago

We need to add a display: grid on ".wp-block-group.global-footer>.global-footernavigation-container"class under https://wordpress.org/wp-content/mu-plugins/pub-sync/blocks/global-header-footer/build/style.css to fix the footer layout.

.wp-block-group.global-footer>.global-footer__navigation-container {
    align-items: start;
    grid-template-columns: repeat(auto-fit,minmax(150px,1fr));
    row-gap: 35px;
    display: grid;
}

#3 @paulkevan
8 months ago

Hi @sumitsingh, I can't seem to reproduce what you are seeing, can you provide more details such as browser, and/or web request headers?

#4 @sumitsingh
8 months ago

@paulkevan, here are my system and browser details
Server architecture Linux 5.15.0-84-generic x86_64
Web server Apache/2.4.41 (Ubuntu)
Browser - Google Chrome

here quick recording - https://www.awesomescreenshot.com/video/21274042?key=010b42100e8c87b0549949497efeab69

Last edited 8 months ago by sumitsingh (previous) (diff)

#5 @ryelle
8 months ago

The trac templates need to be synced because this change updated the footer's HTML & CSS. You might not see the issue if the old CSS is still cached.

I should have run templates/update-headers.php as part of merging that PR, I can do it shortly.

#6 @kafleg
8 months ago

There is no such issue in my end.

#7 @ryelle
8 months ago

  • Owner set to ryelle
  • Resolution set to fixed
  • Status changed from new to closed

In 12923:

Trac: Update trac header/footers.

Fixes #7295.

#8 @ryelle
8 months ago

The templates are cached for a number of visits, so it will take some time for the cache to expire- core should clear first, meta might be slower.

#9 @Otto42
7 months ago

#7322 was marked as a duplicate.

Note: See TracTickets for help on using tickets.