WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#738 closed defect (fixed)

Hide "New to translate.wordpress.org?" message permanently

Reported by: SergeyBiryukov Owned by: ocean90
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Each time I go to https://translate.wordpress.org/projects, I see a box at the top:

New to translate.wordpress.org? Have a look at the Getting Started guide.

I click "Hide", but it reappears after a few days or so. There should be a way to hide it permanently.

Change History (5)

#1 @Otto42
5 years ago

If you're logged in, then clicking Hide should set meta for you to hide it permanently. Whether you're logged in or not, it should set a 30 day cookie to make it hide for you as well.

#2 @SergeyBiryukov
5 years ago

I've just clicked Hide while logged in and confirmed that wporg-help-hide-notice cookie is there.

However, once I remove the cookie, the box reappears, so apparently the meta is not set.

#3 @ocean90
5 years ago

Tracked down the issue to https://glotpress.trac.wordpress.org/browser/trunk/gp-includes/things/user.php#L135 where $this->id is null. Still looking for the cause.

#4 @ocean90
5 years ago

In 1125:

GlotPress Help Page Plugin: Call GP::$user->current() before reading/saving meta.

see #738.

#5 @ocean90
5 years ago

  • Owner set to ocean90
  • Resolution set to fixed
  • Status changed from new to closed

In 1126:

GlotPress Help Page Plugin: Use underscores instead of dashes for the meta key. BackPress doesn't support dashes.

fixes #738.

Note: See TracTickets for help on using tickets.