Making WordPress.org

Opened 4 months ago

Closed 4 weeks ago

#7391 closed defect (bug) (duplicate)

In Responsive view, at 768px search button design does not looks proper

Reported by: pranitdugad's profile pranitdugad Owned by:
Milestone: Priority: lowest
Component: Support Forums Keywords: has-screenshots needs-patch
Cc:

Description

In Responsive view, at 768px (ipad mini device view) search button design does not looks proper

Attachments (3)

Screenshot 2023-12-26 at 8.37.50 AM.png (100.7 KB) - added by pranitdugad 4 months ago.
I have attached Screenshot for better Understanding
7391.patch (599 bytes) - added by pranitdugad 4 months ago.
After applying this patch , this issue is resolved
7391.1.patch (1.5 KB) - added by pitamdey 4 months ago.
After applying this solution the issue is resolved

Download all attachments as: .zip

Change History (6)

@pranitdugad
4 months ago

I have attached Screenshot for better Understanding

@pranitdugad
4 months ago

After applying this patch , this issue is resolved

#1 @bedas
4 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #7365.

I think that’s a duplicate of https://meta.trac.wordpress.org/ticket/7365

@pitamdey
4 months ago

After applying this solution the issue is resolved

#2 @dd32
4 months ago

  • Component changed from WordPress.org Site to Support Forums
  • Keywords needs-patch added
  • Priority changed from low to lowest
  • Resolution duplicate deleted
  • Status changed from closed to reopened

Not a duplicate of #7365, but similar.

Affected URL: https://wordpress.org/support/forums/

Patches above appear irrelevant, this is an off-by-one pixel in the media query rules (Probably less-than, instead of less-than-or-equal-to), not present at 767px width, not present at 769px, only present at 768px.

Setting priority to super-low, since this is so nitpicky resolution that it's hardly worth the time writing this comment.

#3 @coffee2code
4 weeks ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

This is actually a duplicate of #6860 (though admittedly that ticket didn't provide much context).

Ultimately, as Dion alluded to, the issue at hand is that the theme's styles make use of a breakpoint at 48em (768px) via both the @media screen and (min-width: 48em) and @media screen and (max-width: 48em). Unfortunately, at the breakpoint both grouping of rules applies. Bumping the max-width down by 1px was sufficient to resolve the issue. The issue will be fixed via the original ticket. Unfortunately, as Dion also noted, the patches from this ticket were not concise enough to be used.

Note: See TracTickets for help on using tickets.