Making WordPress.org

Opened 2 months ago

Closed 2 months ago

#7454 closed defect (bug) (invalid)

Improved Search Box & add validation

Reported by: pitamdey's profile pitamdey Owned by:
Milestone: Priority: lowest
Component: Make (Get Involved) / P2 Keywords: has-screenshots
Cc:

Description

URL : https://make.wordpress.org/core/?s=
Just for an improvement can we add validation in the search box? So that it can not search for blank text and we can also add a search button there instead of only searching by clicking enter.

Attachments (1)

Screenshot 2024-02-08 at 10.30.25 AM.png (347.5 KB) - added by pitamdey 2 months ago.
Screenshot for better understanding

Download all attachments as: .zip

Change History (2)

@pitamdey
2 months ago

Screenshot for better understanding

#1 @dd32
2 months ago

  • Component changed from General to Make (Get Involved) / P2
  • Resolution set to invalid
  • Status changed from new to closed

This is likely caused by the underlying o2 plugin in use on this site, or WordPress itself (As it's loading the search.php template)

As it also appears to be on https://wordpress.org/news/?s= then this is likely a Core bug, and should be reported to https://core.trac.wordpress.org/

After looking into it, it appears that this is the intentional WordPress behaviour, although it seems wrong to me.

https://core.trac.wordpress.org/ticket/11330

Note: See TracTickets for help on using tickets.