WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#747 closed defect (worksforme)

"Lengths of source and translation differ too much" warning for all strings

Reported by: SergeyBiryukov Owned by: ocean90
Milestone: Priority: normal
Component: Translate Site & Plugins Keywords:
Cc:

Description

Previously reported in #368-glotpress, but appears to be specific to translate.wordpress.org. See also Slack discussions in #polyglots and #glotpress.

I get a "Lengths of source and translation differ too much" warning for each string I translate.

See the screenshots, those strings surely do not differ that much. Not sure why they were showing up as untranslated or fuzzy for all locales in the first place, as none of them are new to 4.0.1. It was probably a result of the duplication bug resolved earlier.

I've discarded the warnings for now to have the translation back at 100%, but it can easily be reproduced by suggesting a new translation for any of the strings on the screenshots.

Attachments (4)

meta-747.wp-dev.png (55.4 KB) - added by SergeyBiryukov 5 years ago.
meta-747.wp-dev-admin.png (49.0 KB) - added by SergeyBiryukov 5 years ago.
meta-747-buddypress-dev-fr_FR.png (40.4 KB) - added by netweb 5 years ago.
meta-747-buddypress-dev-en_AU.png (42.9 KB) - added by netweb 5 years ago.

Download all attachments as: .zip

Change History (15)

#1 @netweb
5 years ago

The following string (per above screenshots) in BuddyPress displays the warning for the French translation though if I use the same French translation string for en_AU I do not get the warning:

This ticket was mentioned in Slack in #polyglots by xavier. View the logs.


5 years ago

This ticket was mentioned in Slack in #polyglots by netweb. View the logs.


5 years ago

#4 @so_vichet
5 years ago

It occurs in Khmer translation as well.

This ticket was mentioned in Slack in #polyglots by deconf. View the logs.


5 years ago

#6 @ocean90
5 years ago

  • Owner set to ocean90
  • Status changed from new to reviewing

#7 @egill
5 years ago

Happens in Icelandic as well, and says 26 strings are not translated (not true).

#8 @egill
5 years ago

Additional errors appearing once I disrecard the "Lengths of translation differ too much":

Warning: Extra %s placeholder in translation.
Warning: Too many tags in translation.
Last edited 5 years ago by egill (previous) (diff)

This ticket was mentioned in Slack in #polyglots by netweb. View the logs.


5 years ago

This ticket was mentioned in Slack in #polyglots by netweb. View the logs.


5 years ago

#11 @SergeyBiryukov
5 years ago

  • Resolution set to worksforme
  • Status changed from reviewing to closed

Looks like the issue is gone, I can no longer reproduce it.

Note: See TracTickets for help on using tickets.