Making WordPress.org

Opened 8 weeks ago

Closed 6 weeks ago

Last modified 6 weeks ago

#7529 closed enhancement (fixed)

New Theme Lacks Different Color for Visited Links

Reported by: macmanx's profile macmanx Owned by:
Milestone: Priority: normal
Component: Support Forums Keywords:
Cc:

Description

It would be nice if the new theme visually made a distinction between visited and not visited links.

I know it sounds a bit old school, but from a moderator's perspective, it's a handy way to be aware of which threads we've already individually triaged.

For example, in the no-replies attached screenshots, you can see where I left off as far as threads with no replies are concerned on old-theme, but not new-theme.

And, in the all-topics attached screenshots, you can see which topics I still need to triage on old-theme, but not new-theme.

A simple a:visited would make a world of difference. :)

Thanks!

Attachments (5)

all-topics-new-theme.png (302.8 KB) - added by macmanx 8 weeks ago.
All Topics, Old Theme
all-topics-old-theme.png (301.2 KB) - added by macmanx 8 weeks ago.
All Topics, Old Theme
no-replies-new-theme.png (265.9 KB) - added by macmanx 8 weeks ago.
No Replies, New Theme
no-replies-old-theme.png (248.6 KB) - added by macmanx 8 weeks ago.
No Replies, Old Theme
less-link-colors.png (227.9 KB) - added by dufresnesteven 7 weeks ago.

Download all attachments as: .zip

Change History (14)

@macmanx
8 weeks ago

All Topics, Old Theme

@macmanx
8 weeks ago

All Topics, Old Theme

@macmanx
8 weeks ago

No Replies, New Theme

@macmanx
8 weeks ago

No Replies, Old Theme

#1 @bcworkz
8 weeks ago

The desire to distinguish between visited and not visited links goes beyond "it would be nice" from my perspective. It is essential to my support forum workflow. IMO even the old styling of lighter/darker blue was little weak. Adequate but weak.

The difference doesn't have to be as dramatic as old school blue vs. magenta, but a slightly different hue as well as darker/lighter would be meaningful.

#2 follow-up: @dufresnesteven
7 weeks ago

Thanks.

I've reported this upstream in the theme:
https://github.com/WordPress/wporg-parent-2021/issues/128

#3 in reply to: ↑ 2 @macmanx
7 weeks ago

Replying to dufresnesteven:

Thanks!

#4 follow-ups: @dufresnesteven
7 weeks ago

Would it also make sense to only leave the issue title as the blue link color?

I feel like the large majority of users don't need to click on users or timestamps. We can leave them as links but demote them in the experience.

#5 in reply to: ↑ 4 @macmanx
7 weeks ago

Replying to dufresnesteven:

Would it also make sense to only leave the issue title as the blue link color?

I feel like the large majority of users don't need to click on users or timestamps. We can leave them as links but demote them in the experience.

Personally, for me that makes sense. Keep the topic title blue with a darker shade for a:visited.

I wouldn’t go as far as the mockup though, maybe a lighter shade in the realm of 777 for the other links, to both mute it but also distinguish it from non-clickable text.

#6 in reply to: ↑ 4 @bcworkz
7 weeks ago

Replying to dufresnesteven:

Would it also make sense to only leave the issue title as the blue link color?

I feel like the large majority of users don't need to click on users or timestamps. We can leave them as links but demote them in the experience.

From my standpoint, my current workflow requires the timestamps visited or not to be distinguishable. If that offends everyone's sensibilities I'm pretty sure I can override the default CSS through a browser extension. What I'm doing is scanning engagements for new replies because it's a lot faster for me than sifting through individual notifications. I realize I'm unusual and the entire site needn't cater to my quirks. But if at all possible I'd like unvisited timestamps to be distinguishable.

This ticket was mentioned in Slack in #forums by dufresnesteven. View the logs.


7 weeks ago

#8 @adamwood
6 weeks ago

  • Resolution set to fixed
  • Status changed from new to closed

Changed the visited link color as per the discussion here https://github.com/WordPress/wporg-parent-2021/issues/128#issuecomment-2029343489

Commit: https://meta.trac.wordpress.org/changeset/13434

There is further discussion on whether to make this change globally on the GitHub issue, but for this site the issue is fixed.

#9 @macmanx
6 weeks ago

Thanks! :)

Note: See TracTickets for help on using tickets.