Making WordPress.org

Opened 7 weeks ago

Closed 7 weeks ago

#7616 closed enhancement (invalid)

.xyz domains error in WordPress.org profile edit form

Reported by: antpb's profile antpb Owned by:
Milestone: Priority: low
Component: Profiles Keywords:
Cc:

Description (last modified by dd32)

Hello! I'm seeing an error when attempting to save any .xyz domain in my profile. To reproduce, in the website section of your profile add something.xyz and see

Uncaught TypeError: Cannot read properties of undefined (reading 'replace')
    at Function.template (underscore.min.js?ver=1.13.4:2:14731)
    at Object.success (functions.js?ver=20191120:44:29)
    at c (jquery.min.js?ver=3.7.1:2:25304)
    at Object.fireWith [as resolveWith] (

I saw that https://meta.trac.wordpress.org/ticket/6421 was opened in the past for this and was able to get it solved at the specific domain level, but I'm wondering if we need something more permanent for future folks hitting this. This is not a unique problem, spam filters often with good reason auto-send .xyz domain emails to spam.

The website field in my profile I was attempting to set was 3ov.xyz which YES I have domain regrets and sadly can't really change it at the moment. Feel free to close if this still isn't a big enough issue.

Change History (2)

#1 @Otto42
7 weeks ago

How can we reproduce this? What page are you trying to edit? And what field and so on? Please give us the specific instructions.

#2 @dd32
7 weeks ago

  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed

It looks like the JS error you're seeing is unrelated, I'm not sure what component it's coming from though.

The website field in my profile I was attempting to set was 3ov.xyz which YES I have domain regrets and sadly can't really change it at the moment. Feel free to close if this still isn't a big enough issue.

I've updated your profile.

In short: Akismet believed your profile was spam, the description combined with .xyz likely pushed it over the threshold, unfortunately many .xyz domains are full of spam so I'm guessing it's heavier in their algorithms (I know nothing about the internals of Akismet)

Note: See TracTickets for help on using tickets.