Making WordPress.org

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#7639 closed enhancement (maybelater)

plugin name can break support forum search

Reported by: willemb2's profile willemb2 Owned by:
Milestone: Priority: low
Component: Support Forums Keywords:
Cc:

Description

The 'Support Threads' for plugins and themes have a search box above the list of topics. This box constructs a search URL on the entire wordpress.org forum filtering on the name of the plugin. Plugin publishers sometimes manage to choose names that break this search function. Sometimes you get no results at all, sometimes you get results from other plugins.

I'm using WPCode as example here, but I've seen similar issues with other plugins. Stepls to reproduce:

Expected result: at least 1 hit
Actual result: none

My guess is that in this case the '+' character in the plugin name brakes the search.

I do not have the knowledge to suggest a technical solution. Another approach would be to document the limitations of the search function and advise the plugin publishers which characters and strings not to use in their plugin name.

Change History (4)

#1 @Otto42
5 weeks ago

  • Priority changed from normal to low
  • Resolution set to maybelater
  • Status changed from new to closed
  • Type changed from defect (bug) to enhancement

The search is not broken by the characters, the search is as it is because it is Google powered, and Google hasn't indexed all of the forums.

Until we implement our own search, this isn't likely to change.

#2 @willemb2
5 weeks ago

@Otto42 I tried the word 'snippets'. On the 'No results' page it shows a search box with:

snippets intext:"Plugin: WPCode - Insert Headers and Footers   Custom Code Snippets - WordPress Code Manager"

When I edit that to:

snippets intext:"Plugin: WPCode"

I get hundreds of results, all topics from the WPCode forum. In '(0.30 seconds)' they claim. Doesn't this mean that it has been indexed?

#3 @Otto42
5 weeks ago

It means that they have indexed things that contain that text, which is not the specific name of the plugin.

There really is not anything we can do here, it's just a thing where they are using the wrong texts and basically it's Google. We cannot control what Google does. The only thing we can do with it is to stop using Google... and that's it. We're not there yet.

#4 @dd32
5 weeks ago

Just noting, that this will probably be resolved by moving to ElasticSearch for the support forum: #3388

I agree that there's nothing we can do here currently though.

Note: See TracTickets for help on using tickets.