Making WordPress.org

Opened 4 weeks ago

Last modified 3 weeks ago

#7653 new defect (bug)

Sustainability team site displays no og:image

Reported by: courane01's profile courane01 Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

Featured images have been used in posts on the Sustainability team site. Jetpack is installed and displays what the preview should look like. The featured image is also even displayed at the top in one of the posts. Yet when shared across Slack and social media sites, no og:image is found.

Attachments (2)

Screenshot 2024-05-24 at 12.19.06 PM.png (780.1 KB) - added by dd32 4 weeks ago.
Screenshot 2024-05-24 at 1.58.30 PM.png (1.1 MB) - added by dd32 4 weeks ago.

Download all attachments as: .zip

Change History (6)

#1 @dd32
4 weeks ago

The Facebook debugger seems to show these datapoints as being set, see the above image and the below URL.

https://developers.facebook.com/tools/debug/?q=https%3A%2F%2Fmake.wordpress.org%2Fsustainability%2F2024%2F05%2F22%2Fproject-health-hangouts-and-working-group-kickoff%2F

Confirmed it's in the HTML too:

$ curl -s https://make.wordpress.org/sustainability/2024/05/22/project-health-hangouts-and-working-group-kickoff/ | grep 'og:image'
<meta property="og:image" content="https://make.wordpress.org/sustainability/files/2024/05/project-health-working-group-Medium.jpeg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="366" />
<meta property="og:image:alt" content="An image featuring a diverse group of people sitting on the same side of a table facing the viewer. The group includes individuals of various ages, skin tones, and genders. Visible are a blind person with a guide dog, a pregnant person, someone with a cast on their arm, a person wearing a hijab, and a woman wearing a tichel. The backdrop is a simple flat world map with four clocks showing different times." />

@courane01 Can you confirm that this seems working? Or at least point out where it's not working?

I thought I might've fixed it through #7654 but the Facebook debugger shows it was fetched a few minutes into an hour long struggle with that, so I don't think I affected it..

#2 @courane01
4 weeks ago

Ah, it isn't working on basically everywhere except Facebook! X namely, but also Mastodon, Bluesky, LinkedIn, Slack isn't picking it up, nor Discord. Whew ... that was a long list.

#3 @dd32
4 weeks ago

I tried a Mastodon embed, and that seems to work.

I don't doubt this was not working before, but it seems to be working now, as far as I can tell.

I think we'll need to wait for the next post to be made to confirm whether it's working properly or not.

This ticket was mentioned in Slack in #meta by courtneyengle. View the logs.


3 weeks ago

Note: See TracTickets for help on using tickets.