WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 18 months ago

#766 closed enhancement (duplicate)

Community calendar on make.wordpress.org for chats

Reported by: samuelsidler Owned by:
Milestone: Priority: normal
Component: Make (Get Involved) / P2 Keywords:
Cc:

Description

We've talked about it before, but we should create a community calendar on make.wordpress.org that lists all Slack chats. I imagine it will live at make.wordpress.org/meetings/ since we already use /chat/.

The "calendar" should appear as a list in the currently logged-in user's timezone and display the upcoming chat date, times, subject, team, and channel. The subject should optionally be linked.

We don't yet have a design for this, but I'm sure we can create one if we have the backend built. However, in theory, we should display the most recent upcoming chats first and allow (JS-based) filtering by team and channel. Likewise, we could display older chats somewhere as well.

On the backend, we need to allow for entering upcoming chats as either one-off or recurring weekly. We should only support entering chats in the UTC timezone.

For anyone interested in this, the code for the make.wordpress.org theme is here: https://meta.trac.wordpress.org/browser/sites/trunk/wordpress.org/public_html/wp-content/themes/pub/wporg-makehome

Change History (2)

This ticket was mentioned in Slack in #themereview by sam. View the logs.


3 years ago

#2 @samuelsidler
18 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #506.

Note: See TracTickets for help on using tickets.