WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#775 closed defect (fixed)

Theme Repository Uploader Fails Usage of 4.1 API Features

Reported by: iandunn Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

The theme repo needs to be updated to allow the new theme API features in 4.1.

The failures can be reproduced by attempting to upload TwentyFifteen.

Change History (5)

#1 @Otto42
5 years ago

Actually, theme-check needs to be updated to account for it. Then theme-check needs to be updated on the theme uploader.

Theme Check is now on github if you want to help address any known issues, or report issues you've found.

https://github.com/Otto42/theme-check

#2 @iandunn
5 years ago

Ah, I didn't notice it was a library; I'll open the issue there and leave this as a reminder for us to update our copy after it's resolved.

I don't think I'll have time to work on it any time soon, but I noticed it while working on something else and wanted to at least get it reported.

#3 @iandunn
5 years ago

Actually, it looks like #10 and #15 already cover it.

#4 @Otto42
5 years ago

It's not exactly a library, yet. It's just select parts of the plugin on the dotorg repo. But it will be a plugin in the new theme directory, eventually. Saves me from having to update multiple things.

#5 @iandunn
5 years ago

  • Resolution set to fixed
  • Status changed from new to closed

#10 and #15 are fixed now.

Note: See TracTickets for help on using tickets.