WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 3 years ago

Last modified 18 months ago

#838 closed defect (fixed)

Ticket titles for ticket update notifications in Slack are truncated

Reported by: netweb Owned by: ocean90
Milestone: Priority: high
Component: Slack & IRC Keywords: needs-patch
Cc:

Description (last modified by ocean90)

In #buddypress-firehose it reads netweb updated #6064 ocess., it should read netweb updated #6064 Make existing Grunt tasks clearer, and improve the release packaging process.

A good example of a recent truncated title and tickets without titles:

https://wordpress.slack.com/archives/buddypress-firehose/p1422872830000113

Related discussions:
https://wordpress.slack.com/archives/meta/p1422945632000413
https://wordpress.slack.com/archives/meta/p1422591851000295

Change History (16)

#1 @netweb
4 years ago

  • Owner set to nacin
  • Priority changed from normal to high
  • Status changed from new to assigned

Not sure what the cause of this is but is annoying for me at least, I've set you as the owner @Nacin if you don't mind taking a look at this please :)

Maybe a configuration in http://lists.automattic.com/mailman/listinfo/buddypress-trac that is different to other list configs?

A specific example without any title text (the vast majority have no title text at all)

A specific example of partial title text (these are the minority)

#2 @nacin
4 years ago

This one looks like fun.

The Trac firehose stuff works by reading raw mail data line by line from stdin, so it probably just has a weird string concatenation bug. :-)

#3 @netweb
4 years ago

Just noticed that #glotpress-firehose is also affected by this.

#4 @netweb
4 years ago

Another instance in #core-firehose:

https://core.trac.wordpress.org/ticket/32515#comment:2
http://lists.wordpress.org/pipermail/wp-trac/2015-May/256292.html
https://wordpress.slack.com/archives/core-firehose/p1432789555000465

Actual:

  • updated #32515 Don't declare class properties readonly if they're written to later

Expected:

  • netweb updated #32515 Don't declare class properties readonly if they're written to later

#5 @netweb
4 years ago

Here's something slightly different but related, I think:

https://wordpress.slack.com/archives/core-firehose/p1433788225001392

Current:

johnbillion updated <https://core.trac.wordpress.org/ticket/32584#comment:1%7C#32584 Missing links in admin bar when body_class() is placed in <html> or in <body> and <html>>

Expected:

johnbillion updated #32584 Missing links in admin bar when body_class() is placed in <html> or in <body> and <html>

#6 @netweb
4 years ago

More in the related encoding world of Slack messages via trac

This ticket was mentioned in Slack in #meta by netweb. View the logs.


4 years ago

This ticket was mentioned in Slack in #meta by netweb. View the logs.


4 years ago

#9 @ocean90
4 years ago

In 2703:

Slack: In commit messages convert ASCII numbers with a UTF-8 char.

It's unclear which system is producing the weird encoding but this should fix it at least for Slack messages.

See #838.

#10 @ocean90
4 years ago

In 2704:

Slack: Improve the comment added in [2703].

And here are some fancy characters for testing purposes: …, —, “, ’, and ”.

#11 @ocean90
3 years ago

In 3069:

Slack: Fix missing author for ticket description changes.

See #838.

#12 @ocean90
3 years ago

In 3070:

Slack: When parsing the author of a ticket change exclude the closing parenthesis.

See #838.

#13 @ocean90
3 years ago

  • Description modified (diff)

#14 @ocean90
3 years ago

  • Description modified (diff)
  • Owner changed from nacin to ocean90

#15 @ocean90
3 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 3072:

Slack: Don't remove the first line if the Trac mail is base64 encoded.

If the mail is base64 encoded the first line contains the title and is *not* empty.

Fixes #838.

#16 @ocean90
3 years ago

In 3085:

Slack: In Commit::format_commit_for_slack() match only ASCII numbers which have 1-3 digits.

Introduced in [2703].

See https://wordpress.slack.com/archives/core/p1462134505002817.
See #838.

Note: See TracTickets for help on using tickets.