WordPress.org

Making WordPress.org

Opened 5 years ago

Closed 5 years ago

#848 closed defect (invalid)

Url not updating on first click after 'Feature Filter'

Reported by: OriginalEXE Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

This is a bug on new themes directory found https://wordpress.org/themesnew/

How to reproduce the issue:
Go to the url above, click on 'Feature Filter', and then click on any of the other three nav items (Featured, Popular, Latest).

Expected behaviour:
Url should reflect the chosen sorting criteria.

What actually happens:
Url does not reflect the change. Upon further selecting of another sorting criteria or re-selecting the same one, url updates as it should.

Note: The above 'bug' is not consistent, so sometimes it works properly. I found that if it does not happen on the first try, it will happen on the second (go to site -> click 'feature filter' -> click 'popular' -> click 'feature filter' -> click 'popular')

Tested in:
Latest Chrome and Firefox on Ubuntu

Change History (1)

#1 @obenland
5 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for submitting this ticket!

The reason the URL is not updated is that the sorting didn't change. It shows featured themes by default, so requesting featured themes again doesn't change anything.

Note: See TracTickets for help on using tickets.