WordPress.org

Making WordPress.org

Opened 3 years ago

Closed 3 years ago

#853 closed defect (invalid)

New Theme repository design: Issues on mobile

Reported by: daveshine Owned by:
Milestone: Priority: normal
Component: Theme Directory Keywords:
Cc:

Description

Currently I found these issues on mobile (state 2015-02-06):

1) it is kind of hard to intentify the theme's deep link on mobile

2) the JavaScript popup leads to a horrible user experience on mobile

3) in the repository overview https://wordpress.org/themesnew/ touching/ clicking a theme often does not open the popup but directly leads to the preview of the theme. This is totally unexpected and confusing!

4) handling of the preview on mobile is horrible as well!

5) hiding the last updated date and/ or publishing date of the theme behind a tooltip is really bad: unaccessable on mobile (except for stylus users on Samsung's Note devices...)

6) all other issues of ticket #852 also apply to this one here

In the current state I would not open this new theme repository version to the public. I see no advantages over the old one yet.

Change History (6)

#1 @obenland
3 years ago

Thank you for opening a ticket and bringing those issues to our attention. Could you be a little more specific as to what your expectations were and where you see the short comings?

1) How did you expect a deeplink to be made obvious?

2) What makes the user experience horrible and how do you think we can improve it?

3) You said it happens often, so I assume it doesn't happen all the time? What would be steps to reproduce it consistently?

4) How can we make the preview handling on mobile better?

5) Agreed. Where would you expect to find it instead?

Thanks

#3 follow-up: @daveshine
3 years ago

@obenland:
Sorry for the delay!

1) "By accident" I was first viewing the new repo (preview) on mobile before later on desktop. That was confusing for me and irritating so I missed the "deeplink" somehow. Later I realized on desktop that the regular theme (deep) URL is still be used like ever.

2) The "popup" on mobile is wasting some real estate: even if only a few pixels, it should be avoided on mobile. The whole JS powered view is somewhat great but from my experience not as intuitive as a regular page on a website.

  • Loading the full images mostly??? (smaller ones for mobile?)
  • preview handling IMHO should be re-thought?!?
  • direkt to theme developer or original theme page missing - I consider this important to get more info about developer/theme shop or similar, because often profile pages from authors on .org are missing lots of info. It's often very hard to find original theme site and the original theme demo!

3) I will test again with the live repo and many mobile browsers and report any issues I have - sorry for the delay on my behalf.

4) Currently no idea but I had trouble to find the close button on the site - wouldn't be opening in a new tab a better compromise? However I test again with live repo.

5) Somewhere around the theme title container (in that area), could be smaller font but somehow visible as additional info

Now that the repo is live, which is still an achievement in its own, I totally know and respect, there may still be improvements made to it. At least I hope so.

My wishlist:

  • changelogs (like plugins)
  • other notes or so (like plugins)
  • link to original theme site/demo/developer

Thanks!!

#4 @daveshine
3 years ago

@melchoyce:
Thank you, this is great! Also with the theme page link ;-)

Is this still up for implementation and/discussion or got that canceled now it's live?

#5 in reply to: ↑ 3 @obenland
3 years ago

Replying to daveshine:

2) The "popup" on mobile is wasting some real estate: even if only a few pixels, it should be avoided on mobile.

It's using all available space as of r1303.

  • Loading the full images mostly??? (smaller ones for mobile?)

Images are loaded as small as possible while still providing HiDPI support.

  • preview handling IMHO should be re-thought?!?

Can you be more specific about what you have in mind?

  • direkt to theme developer or original theme page missing

This will be addressed as part of #908.

5) Somewhere around the theme title container (in that area), could be smaller font but somehow visible as additional info

@melchoyce is working on a design approach for this, also as part of #908.

Now that the repo is live, which is still an achievement in its own, I totally know and respect, there may still be improvements made to it. At least I hope so.

My wishlist:

  • changelogs (like plugins)
  • other notes or so (like plugins)

Requested in #215, but will not be part of this iteration.

#6 @obenland
3 years ago

  • Resolution set to invalid
  • Status changed from new to closed

The only thing that seems open here is the re-thinking of previews.

If this is not about the theme demo data from #30, please open a new ticket with a concrete proposal.

Note: See TracTickets for help on using tickets.